Last Comment Bug 416065 - MathML tilde, check and hat accents don't stretch
: MathML tilde, check and hat accents don't stretch
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal with 1 vote (vote)
: mozilla2.0b4
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 407101 scale-stretchy 427659
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 21:56 PST by distler
Modified: 2010-08-22 06:10 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (3.10 KB, application/xhtml+xml)
2008-02-06 21:56 PST, distler
no flags Details
incorrect rendering for wide-tilde, wide-check and wide-hat (44.64 KB, image/png)
2008-02-06 21:59 PST, distler
no flags Details
rendering from Camino (in which these accents do stretch) (35.56 KB, image/png)
2008-02-06 22:00 PST, distler
no flags Details
Testcase 2 (3.10 KB, application/xhtml+xml)
2010-01-24 04:04 PST, Bill Gianopoulos [:WG9s]
no flags Details

Description distler 2008-02-06 21:56:22 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008020201 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008020201 SeaMonkey/2.0a1pre

These math accents are supposed to stretch. In current trunk, they don't.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 distler 2008-02-06 21:56:59 PST
Created attachment 301824 [details]
testcase
Comment 2 distler 2008-02-06 21:59:23 PST
Created attachment 301825 [details]
incorrect rendering for wide-tilde, wide-check and wide-hat
Comment 3 distler 2008-02-06 22:00:39 PST
Created attachment 301826 [details]
rendering from Camino (in which these accents do stretch)
Comment 4 distler 2008-03-09 15:39:23 PDT
Hmmm, in the latest nightlies (Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008030701 SeaMonkey/2.0a1pre), the \overline and \hat accents in the testcase are screwed up as well.
Comment 5 Karl Tomlinson (:karlt) 2008-03-10 13:36:56 PDT
(In reply to comment #4)
That sounds like bug 421955.
Comment 6 distler 2008-03-10 14:00:57 PDT
It sure looks like it is. But will be good to check back when that bug is fixed.
Comment 7 distler 2008-03-28 21:08:41 PDT
In the latest nightlies, the \hat (and \widehat) accents have entirely disappeared.
Comment 8 Karl Tomlinson (:karlt) 2008-03-31 22:02:59 PDT
(In reply to comment #7)
> In the latest nightlies, the \hat (and \widehat) accents have entirely
> disappeared.

I don't know why that's changed.

^ represents U+005E and which seems to render (even if it doesn't stretch), but this test case uses U+0302, which doesn't render.  Would you mind filing a separate bug on that being missing, please?  Do you know how often U+0302 is used for accents?  It doesn't seem to be in the sample operator dictionary:

http://www.w3.org/TR/2007/WD-MathML3-20071214/appendixb.html#oper-dict.entries
Comment 9 distler 2008-03-31 23:39:48 PDT
>^ represents U+005E and which seems to render (even if it doesn't stretch),
but this test case uses U+0302, which doesn't render.

Hmmm. This was changed in itex2MML 1.1.2, to work around a then-current  (5/2006) bug in Gecko.

I could change it back, but there would still be content out there, created in the past two years, using U+0302.

>Would you mind filing a separate bug on that being missing, please?

I will do so tomorrow.
Comment 10 distler 2009-05-18 17:40:40 PDT
This bug still seems to be present in the latest Gecko Trunk
Comment 11 Bill Gianopoulos [:WG9s] 2010-01-24 03:57:14 PST
(In reply to comment #9)
> >^ represents U+005E and which seems to render (even if it doesn't stretch),
> but this test case uses U+0302, which doesn't render.
> 
> Hmmm. This was changed in itex2MML 1.1.2, to work around a then-current 
> (5/2006) bug in Gecko.
> 
> I could change it back, but there would still be content out there, created in
> the past two years, using U+0302.
> 

U+0302 is defined as a combining circumflex.  It's purpose is to display a circumflex over the following character thus combining this pair of Unicode characters to form a single displayed symbol.

As such, IMHO it should never stretch.
Comment 12 Bill Gianopoulos [:WG9s] 2010-01-24 04:04:50 PST
Created attachment 423222 [details]
Testcase 2

This is the same as the original testcase with the exception of using U+005E for the hat rather than the incorrect U+0302.

This testcase renders correctly in builds that contain the patches attached to bu 519126, bug 524275 and bug 414277.
Comment 13 Bill Gianopoulos [:WG9s] 2010-01-24 04:14:08 PST
(In reply to comment #11)
> U+0302 is defined as a combining circumflex.  It's purpose is to display a
> circumflex over the following character thus combining this pair of Unicode
> characters to form a single displayed symbol.
> 
> As such, IMHO it should never stretch.

I realize it is incorrect to say it should never stretch.  I suppose if the
following character stretches it could be stretched to the same width.  But the
point is that by definition, it should always be only over the following
character, so should not stretch to cover the width of the 3 characters in the
given testcase.

Sorry for the bugspam.
Comment 14 Frédéric Wang (:fredw) 2010-01-24 11:45:58 PST
> This is the same as the original testcase with the exception of using U+005E
> for the hat rather than the incorrect U+0302.

I think your right. MathML Operator Dictionary (and also our version) contains U+005E but not U+0302.

Note You need to log in before you can comment on or make changes to this bug.