Closed Bug 416350 Opened 12 years ago Closed 2 months ago

If the localized metadata for an add-on does not include a value for a property then the value from the default metadata should be used

Categories

(Toolkit :: Add-ons Manager, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: morac, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020504 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020504 Minefield/3.0b4pre

I updated my extension to use the new localization scheme in the install.rdf file.  The only data I wanted localized was the extension name and description.  I did not want to localize the creator, contributors, homepage, etc.

I figured that if I did not specify a specific metadata entry in the localized tags for a specific locale, that it would use the default data.  It turns out it does not.

So when I look at the about page for my extension for any other locale other than en-US, there is no data on it except for the extension name and description.

I realize I could just repeat all the other metadata for every locale I have, but with 23 locales that is a lot of repeating for what is the same data.

I'm not sure if this is a bug or not, but can you please use the default metadata unless specifically overridden by a tag inside the localization tag?

Reproducible: Always

Steps to Reproduce:
1. Add default metadata tags and specific localization tags.
2. Switch to a non en-US locale and open the about screen.

Actual Results:  
Only the metadata listed inside the localization tags is displayed.

Expected Results:  
The default metadata should display if not specifically overridden by the same metadata tag in the localization tag.

If the user does not want to have default metadata, they can just create a en-US localization.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I figured it would be a good idea to attach an install.rdf.  In this case all I want to do is override the name and description.  To get this to display correctly in Firefox 3 about extension screen, I need to copy and past the 30 lines at the top into every localization.  This increases the file size from around 8.5 KB to about 53.5 KB and makes the file harder to maintain when adding contributors or translators.
Product: Firefox → Toolkit
No longer blocks: 515049
Duplicate of this bug: 562290
Blocks: abp
Is this fixed in the new Addons Manager? this is really annoying.
(In reply to comment #3)
> Is this fixed in the new Addons Manager? this is really annoying.

No
Bug 562290 proposes a fix which is a really simple one.
This bug effects all platforms, not just Windows (XP). 

This should really be fixed, especially since the new Addons Manager now displays the name of the creator on the top level. So far for addons, which used there own aboutURL, this bug might not have had any impact but in the new Addons Manager the line where is usually says "By <CreatorName>" will be empty.
Summary: Firefox 3: If localized metadata not specified, Firefox should use default metadata → Firefox 3/4: If localized metadata not specified, Firefox should use default metadata
Duplicate of this bug: 394999
Duplicate of this bug: 607364
OS: Windows XP → All
Hardware: x86 → All
Summary: Firefox 3/4: If localized metadata not specified, Firefox should use default metadata → If the localized metadata for an add-on does not include a value for a property then the value from the default metadata should be used
Priority: -- → P3

This is about legacy extensions which are no longer supported. I don't think webextensions have a similar issue, but if they do we should start fresh with a new bug.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.