[Collector Extension] No Credits in About

VERIFIED FIXED in BW-1.1

Status

addons.mozilla.org Graveyard
Collector Extension
P3
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: kinger, Assigned: kinger)

Tracking

unspecified
BW-1.1
x86
All

Details

Attachments

(2 attachments)

(Assignee)

Description

8 years ago
Created attachment 399071 [details]
Person-less About

Credits are missing in About, but present in install.rdf. See acreenshot.
(Assignee)

Comment 1

8 years ago
This is logged as item 1 in bug 394999. Worthy of a bug on its own I think.

What I basically discovered is that, if there are em:localized blocks in install.rdf, none of the following properties are recognised unless they are put inside the localized block.

creator, contributor, developer, translator, homepageURL

I can see a case being made for translator, but all the others should be global.

Dave, am I missing something?
The only other properties are these:

version
optionsURL
iconURL

and they are all working as expected.
The problem is that some people wanted the properties to be additive, some wanted them to fallback to the global and some wanted them to completely separate. With the way it is implemented right now everyone can get the effect they want though it may cause some duplication, much of which can be got around by using entities to define the shared items.
Depends on: 416350
(Assignee)

Comment 4

8 years ago
(In reply to comment #3)
> The problem is that some people wanted the properties to be additive, some
> wanted them to fallback to the global and some wanted them to completely
> separate. With the way it is implemented right now everyone can get the effect
> they want though it may cause some duplication, much of which can be got around
> by using entities to define the shared items.

We'll go with this workaround for now.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

8 years ago
(In reply to comment #4)
> We'll go with this workaround for now.

Checked in, r51114.

Removing dependency, but noting bug 416350

Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 416350
Resolution: --- → FIXED
Created attachment 400813 [details]
Post-fix/workaround screenshot
Verified FIXED.
Status: RESOLVED → VERIFIED
Component: Collections → Collector Extension
QA Contact: collections → collector-extension
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.