Closed Bug 41651 Opened 21 years ago Closed 9 years ago

Relative advanced queries.

Categories

(Bugzilla :: Query/Bug List, enhancement)

2.13
enhancement
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: CodeMachine, Unassigned)

References

Details

Attachments

(2 files)

It would be nice to be able to make queries more relative to whatever the
current circumstances are at query time.  This way more queries would work
without having to be modified.

Examples that come to mind are:

- current milestone (CurrMileStone) (ie Milestone < CurrMilestone)
- current user (Me) (ie Reporter is Me)
- assignee, reporter etc. (ie Comments changed by Assignee)

These would be special values in the third field of advanced querying, like
"NextMilestone" and "Me".
Marking dep on bug #65383, for the current milestone bit.
Depends on: 65383
Target Milestone: --- → Future
Moving to new Bugzilla product ...

Also it would be useful to be able to specify:

Reporter / not equal to / default reporter for component

to be able to find potentially misassigned bugs.
Assignee: tara → endico
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Version: other → 2.13
*** Bug 108926 has been marked as a duplicate of this bug. ***
Depends on: 218036
No longer depends on: 65383
Assignee: endico → nobody
This is small patch for using 'current user' ('%user%') in Bugzilla queries.

With this patch, it possible to use '%user%' in "Advanced Query Charts"
so any query, related to any user, can be relativized
(One URL/CGI-representation of Bugzilla query works specifically for each user).

In our company we publish "common" Bugzilla queries in our Intranet system, 
/*
.../buglist.cgi?query_format=advanced&field0-0-0=requestees.login_name&type0-0-0=equals&value0-0-0=%user%
*/
and all users can receive and store a query, by "click-and-store".
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Future → ---
Assignee: nobody → query-and-buglist
Priority: P3 → --
(In reply to Matthew Tuck [:CodeMachine] from comment #0)
> - current milestone (CurrMileStone) (ie Milestone < CurrMilestone)

There is no definition of current milestone, so you obviously cannot query against it, so invalid.

> - current user (Me) (ie Reporter is Me)
> - assignee, reporter etc. (ie Comments changed by Assignee)

Those are already implemented for a long time, so WFM.


For any other specific request, a separate bug should be filed, with one bug = one request (not a half dozen of ideas ;))
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.