Closed Bug 65383 Opened 19 years ago Closed 16 years ago

Clean up milestone prefs - curmilestone and nummilestones are obsolete.

Categories

(Bugzilla :: Administration, task, P4, trivial)

2.13

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: CodeMachine, Assigned: goobix)

References

()

Details

Attachments

(1 file)

It looks like currmilestone and nummilestones are obsolete.

nummilestones should be removed, and currmilestone should be made per-product.

I will put deps for some bugs that would find this useful.
Blocks: 41651
Blocks: 65388
Whiteboard: 3.0
Summary: Remove obsolete milestone prefs. → Clean up milestone prefs.
Blocks: 40666
Moving to real milestones...
Whiteboard: 3.0
Target Milestone: --- → Bugzilla 3.0
Taking all Bugzilla 3.0 bugs -- congratulations to MattyT for the triage, it
really was spot on. Note: I may end up pushing some of these bugs back to 3.2,
we'll see. However, I believe all these bugs should just fall out of the 
redesign. Let's hope I'm right!

(Note: I'm also resetting the priority field to "---" so that I can retriage any
that I consider important or likely to be dropped.)
Assignee: tara → ian
Component: Bugzilla → Bugzilla 3
The Bugzilla 3 component is going away.  We're going to depend on the Milestones 
for this.  At the time this component was created, we didn't have milestones for 
Bugzilla.
Component: Bugzilla 3 → Bugzilla
Priority: -- → P4
Target Milestone: Bugzilla 3.0 → Bugzilla 2.16
Version: other → Bugzilla 2.13
Component: Bugzilla → Administration
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → 2.13
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
*** Bug 210375 has been marked as a duplicate of this bug. ***
Summary: Clean up milestone prefs. → Clean up milestone prefs - currmilestone and nummilestones are obsolete.
I've grep the source and defparams.pl is the only place where those have remained.
Assignee: ian → jocuri
Status: NEW → ASSIGNED
Attachment #128421 - Flags: review?(kiko)
Comment on attachment 128421 [details] [diff] [review]
Patch. Applied, tested, behaves like expected.

r=kiko (though I wonder if we have to do something in checksetup to disable
these params from previous -- okay, checked with justdave, it's not. cool)
Attachment #128421 - Flags: review+
Flags: approval?
Attachment #128421 - Flags: review?(kiko)
Note one of the goals of this bug (and the prerequisite for bug 41651 and bug
65388) was to make the current milestone be a field on each product.  It makes
well enough sense to separate the tasks though since the existing params are
already useless.  Please file a new bug to add current milestone as a
product-level setting, and move the dependencies.
Flags: approval? → approval+
Vlad: see comment 9

Checking in defparams.pl;
/cvsroot/mozilla/webtools/bugzilla/defparams.pl,v  <--  defparams.pl
new revision: 1.119; previous revision: 1.118
done
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Blocks: 218036
Bug 218036 has been filled addressing this issue. The dependencies have been
updated.
No longer blocks: 40666, 41651, 65388
*** Bug 234241 has been marked as a duplicate of this bug. ***
correcting summary to make dupe searches easier
Summary: Clean up milestone prefs - currmilestone and nummilestones are obsolete. → Clean up milestone prefs - curmilestone and nummilestones are obsolete.
Hello Every Body, I want to know what is exactely the role of mileStones on bugzilla System. is not the same thing as redmine, trac bug trackers .



I need more information of this options, there is no roadmap, user must enter manualy the value of mileStone to each product.

Please  more clarifications
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.