Status

()

Core
XPCOM
P3
critical
VERIFIED DUPLICATE of bug 41414
18 years ago
16 years ago

People

(Reporter: Daniel Egger, Assigned: rpotts (gone))

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla is sometimes crashing at startup time with random messages,
sometimes with segmentation fault and sometimes with illegal instruction.

I manage to get it working though by restarting it about 20 times.

nNCL: registering deferred (0)

Gdk-WARNING **: locale not supported by C library
WEBSHELL+ = 1
WEBSHELL+ = 2
CSSLoaderImpl::LoadAgentSheet: Load of URL 'file:
///root/.mozilla/default/chrome/user.css' failed.  Error code: 16389
CSSLoaderImpl::DidLoadStyle: Load of URL 'chrome://communicator/skin/box.css'
failed.  Error code: 16389
Ungültiger Maschinenbefehl

The last line means illegal instruction.

Unfortunately I cannot further debug it because debugging builds run
fine and the nondebug build is even crashing gdb (version 4.17.0.13 with threads
support as well as 5.0).

The crash itself is REALLY random thus I believe it's a threading problem.
I tried different things like different compilers (currently gcc 2.95.2
otherwise the latest CVS version) different linux kernels, different machines,
different locales and different glibc versions.

This bug is there for me at least 1 month now.

My normal configure options are:
--disable-debug --disable-tests --disable-mailnews

Changing them to other values doesn't help either. Optimized builds are even
more broken and debugging builds don't crash.

I'd really like to try some patch or ideas if someone steps up with something...

Comment 1

18 years ago
Adding crash keyword.
Keywords: crash

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 41414 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Wow, someone finally reproduced my bug.  Thanks, Daniel.

Comment 4

18 years ago
Looks like it's resolved in bug 41414. Marking Verified.
Status: RESOLVED → VERIFIED
Moving all threading bugs to XPCOM. See bug 160356.
Component: Threading → XPCOM
You need to log in before you can comment on or make changes to this bug.