Closed Bug 417428 Opened 12 years ago Closed 12 years ago

offline support/caching

Categories

(Calendar :: Provider: GData, enhancement)

x86
All
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 416851

People

(Reporter: jorohr, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: 

At present, google calendar contents are not at all displayed when the network is not available. 

Reproducible: Always

Steps to Reproduce:
1.Disconnect the computer from the network
2.start thunderbird/lightning
3.look for your calendar entries
Actual Results:  
they are not there. 

Expected Results:  
calendars should be cached for offline usage and synced when the network is back.
What Lightning version and Provider for Google Calendar version do you use? 

Current Lightning 0.8pre nightly test builds have experimental support for offline caching. According to Bug 416851 recent gdata provider nightly builds should support it too.
(In reply to comment #1)
> What Lightning version and Provider for Google Calendar version do you use? 

I'm using the current stable version
 
> Current Lightning 0.8pre nightly test builds have experimental support for
> offline caching. According to Bug 416851 recent gdata provider nightly builds
> should support it too.

Looking forward to testing it. 
Johannes,

You can get a nightly from 

http://gdataprovider.mozdev.org/ 

and will need a calendar nightly from 

ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-mozilla1.8

Please test and report errors if they show up :)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 416851
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.