Change BeOS to invoke improved code

RESOLVED FIXED

Status

()

Core
XPCOM
--
enhancement
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: Doug Shelton, Assigned: Doug Shelton)

Tracking

(Blocks: 1 bug, {fixed1.8.1.13})

Trunk
x86
BeOS
fixed1.8.1.13
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.8.1.12) Gecko/20080209 BonEcho/2.0.0.12
Build Identifier: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.8.1.12) Gecko/20080209 BonEcho/2.0.0.12

It appears the improved code introduced in Bug 140412 was never tried/tested under BeOS.  I'm opening this bug to track my attempt to build with and test this code.

Reproducible: Always
(Assignee)

Updated

9 years ago
Assignee: general → nobody
Component: General → XPCOM
Product: Mozilla Application Suite → Core
QA Contact: general → xpcom
Version: unspecified → 1.8 Branch
(Assignee)

Comment 1

9 years ago
Created attachment 303423 [details] [diff] [review]
Changes BeOS to use newer code

Firefox builds and runs using newer code under BeOS (Zeta).
Attachment #303423 - Flags: review?(thesuckiestemail)
(Assignee)

Updated

9 years ago
Depends on: 140412
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED

Comment 2

9 years ago
Comment on attachment 303423 [details] [diff] [review]
Changes BeOS to use newer code

r=thesuckiestemail@yahoo.se

It would be nice to see what thought any expert on this might have.
Attachment #303423 - Flags: review?(thesuckiestemail) → review+
Assignee: nobody → doug
Status: ASSIGNED → NEW

Updated

9 years ago
Blocks: 181464
(Assignee)

Comment 3

9 years ago
Created attachment 303611 [details] [diff] [review]
Same as before but without the extra blank line.

BeOS-only change to build using gcc code from bug 140412.  Builds/tests OK under BeOS with gcc 2.95.3.
Attachment #303423 - Attachment is obsolete: true
Attachment #303611 - Flags: superreview?
(Assignee)

Updated

9 years ago
Attachment #303611 - Flags: superreview? → superreview?(benjamin)
(Assignee)

Comment 4

9 years ago
Comment on attachment 303611 [details] [diff] [review]
Same as before but without the extra blank line.

cancelling SR request.  Per roc on developers IRC, build changes do not require superreview.
Since this is inside a BeOS-only conditional, it should be quite safe to commit.

I now need to flag to make the change in branch code.  sergei, can you help with the commit, please?
Attachment #303611 - Flags: superreview?(benjamin) → approval1.8.1.13?
Comment on attachment 303611 [details] [diff] [review]
Same as before but without the extra blank line.

Approved for the 1.8 branch before 1.8.1.13. a=ss
Attachment #303611 - Flags: approval1.8.1.13? → approval1.8.1.13+

Comment 6

9 years ago
Checking in mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in,v  <--  Makefile.in
new revision: 1.80.4.6; previous revision: 1.80.4.5
done 
Keywords: fixed1.8.1.13
(Assignee)

Comment 7

9 years ago
thank you, sergei!  If we can, we should also check this in on the trunk so we don't forget.  tqh is making good progress on gcc4 builds for Haiku, so trunk may become important again sometime soon.
was going to close this "FIXED" since it is marked as a branch bug and is fixed there (comment 6), but I guess this is still open as a reminder (comment 7) so changing version to Trunk.
Version: 1.8 Branch → Trunk
(Assignee)

Comment 9

9 years ago
sergei_d, here's another one to place in the trunk when you get a chance.  Daniel, thanks for your patience while we clean things up.

Comment 10

9 years ago
(In reply to comment #9)
> sergei_d, here's another one to place in the trunk when you get a chance. 
> Daniel, thanks for your patience while we clean things up.
> 
Is it appliable to trunk in current form?
(Assignee)

Comment 11

9 years ago
Looks like it should be, though offset a few lines.
http://lxr.mozilla.org/seamonkey/source/xpcom/reflect/xptcall/src/md/unix/Makefile.in#106
Looks like this was fixed a while ago.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.