detaching attachments (from Apple Mail) does not remove them from message

RESOLVED DUPLICATE of bug 351224

Status

MailNews Core
Attachments
RESOLVED DUPLICATE of bug 351224
11 years ago
8 years ago

People

(Reporter: juanb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/2008021305 Thunderbird/2.0.0.12

I tried to detach two attachments in a message, and the attachments were copied correctly to the folder I specified, but the action did not remove the attachments from the message. This happened on pop and imap email accounts (different). 

If I attempt to delete the attachment, it also seems to go through the motions, but the attachment can still be seen in the bottom pane of the message.

Steps:
1. Setup a pop account
2. Send a message with an image or two to yourself (same pop account)
3. Check your mail and select one or more of the attachments
4. Right click to get the context menu and choose to detach them

Expected: Message should refresh with no attachment or attachments

Actual: Attachments are not removed.

Comment 1

11 years ago
"Detach" will leave a "link" to the attachments, so you can easily click on them if they are not (re)moved. Delete deletes them completely (but leaves the attachment placeholder - the name is changed to Deleted:original name.

You might be intersted in bug 292385

Comment 2

10 years ago
Juan's comments are correct - and whilst I've acknowledge Magnus's point, I believe this issue is uniquely associated with attachments sent from Apple Mail (Leopard and Tiger versions), eg "Mime-Version: 1.0 (Apple Message framework v919.2)"

So, confirming, for messages with attachments from Apple Mail:

1. Detach or Detach All copies the file
2. The Detach operation appears to modify state of the attachment
3 [review]. Closing the message reveals no change in size
4. Reopening the message shows the file as originally attached (not "Deleted:")

Comment 3

10 years ago
Detached attachments aren't supposed to get the "Deleted:" prefix...

Comment 4

10 years ago
Dear Magnus, the point isn't what prefix is added, it's that attachments from Apple Mail can not be Detached or Deleted.

Comment 5

10 years ago
Please attach a sample message.
Summary: detaching attachments does not remove them from message → detaching attachments (from Apple Mail) does not remove them from message

Comment 6

10 years ago
Okay Magnus, I've emailed you a sample message - an email from an Apple Mail user with a PDF attachment of about 1MB - it can neither be Deleted or Detached (even though both operations suggest that both were "Successful")

Comment 7

10 years ago
Al, is this perhaps what you reported in your failed litmus test? https://litmus.mozilla.org/single_result.cgi?id=122847
Perhaps but I didn't use Apple Mail to send the original files but Thunderbird itself.

Comment 9

10 years ago
maybe related or more  bug 378729

Comment 10

10 years ago
I think that the specific case is when someone uses OS X's "Mail" program to send an attachment as well as an inline email forward. Thunderbird cannot delete or detach the attachment(s) in that case. The forward shows up as an attachment labeled Part 1.1.3. If that "file" is attached, no other can be detached/deleted. If, however, the sender forwards "as an attachment", any of the attachments can be detached/deleted by thunderbird.

Comment 11

10 years ago
This should be changed to MailNews Core and all platforms, as I see this also under:

Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.17) Gecko/20080925 MultiZilla/1.8.3.5g SeaMonkey/1.1.12

and under Linux (not near a *nix system right now to get a version string, sorry).

Attachments don't detach from Apple Mail and they don't delete, either. Perhaps a minor modification to the subject of this bug is in order, as it pertains to both detaching and deleting.

If we can't remove them for some reason, then we should at least warn that we are unable to do so.

Andrew, per your comment #10, your analysis of the Part 1.1.3 attachment is indeed correct, as a manual mangling of the mbox will prove (whack the 1.1.3 attachment off of the end of the message, and the attachment deletes).

Unfortunately (for me, at least), Mac users are getting to be like typical Windows users (no offense to present company, which is excepted) in that they simply seem to ignore the size of an attachment before sending it (they *can* attach it, so they *do* attach it). This results in huge attachments, bogging down the process for those of us ho receive hundreds of emails per day. I'd love to have the ability to at least zap these attachments before they fill my Inbox (both IMAP & POP3).

Just my additional two cents, FWIW.

Updated

10 years ago
Component: General → Attachments
OS: Windows XP → All
Product: Thunderbird → MailNews Core
QA Contact: general → attachments
Hardware: PC → All
Version: 2.0 → unspecified

Comment 12

10 years ago
Apple Mail tends to send with the multipart "related" headers mentioned in bug #351224 , so this is likely to be the same issue

Updated

9 years ago
Duplicate of this bug: 414339

Updated

9 years ago
Duplicate of this bug: 506946

Comment 15

9 years ago
This is still a problem in TB3.0 unfortunately.

Would love to see this bug squashed as I have a massive OCD problem with attachments and I seem to have lots of Apple Mail users who send me attachments.  Anything I can do (as a non-developer) would be more than happy to help.  I have hundreds of examples of emails that exhibit the problem if needed :)

Comment 16

9 years ago
I concur - TB3 still can't detatch attachments from Mac Mail

Comment 17

8 years ago
Is this bug ever going to be fixed? It was really annoying in TB2. I switched to TB3 today and unfortunately the bug is still there. The bug is very easy to reproduce. Just receive a mail from Apple Mail with attachments and try to delete them - it won't work.

Comment 18

8 years ago
I confirm this bug, and I also note that it propagates to Attachment Extractor as well as to Penelope (Eudora OSE). 

I use a marginally satisfactory workaround:

As soon as you get an email with an attachment from an Apple Mail user (message #1) . . .

Forward it to yourself, with the attachments.  Before clicking on "send", edit the "reply to" header, to equal the address of the offending Apple Mail user.  ("As soon as" in order to preserve the approximate date and time.)  

Now send it, resulting in an automatic copy (#2) in your "sent mailbox".  

Now receive it, resulting in message #3.  You'll find that message #3 has well-behaved attachments that can be detached, deleted, etc.     

Clean up and save disk space, and assuage your OCD, by deleting #1 and #2.

Related comment: one of my Mac correspondents tells me that he clicks on the "make Windows compatible" check box.  He's the one who gives me most trouble.  Perhaps if one does not click, this might solve the problem.

Comment 19

8 years ago
I upgraded to TB 3.0.6 today.

Unfortunately, we still cannot delete attachments from emails sent to us by Apple systems.  With every new TB version I wonder if someone has addressed this, and in every case, they have not.

"Will no-one rid me of this troublesome [bug]?"

Comment 20

8 years ago
Somebody at a higher pay grade than myself should nominate this as a blocker.  Wayne, can you do this?

Comment 21

8 years ago
I am fairly certain that Cathal Garvey is correct in comment 12 that this is a duplicate of bug #351224. I have spent many hours today researching that bug, and I will post my results there. The executive summary is that I think this will be a very hard bug to fix, which is probably why it hasn't been fixed yet.

Comment 22

8 years ago
Someone with the necessary access rights to bugzilla needs to mark this bug as a duplicate of bug 351224.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 351224

Comment 24

8 years ago
(In reply to comment #12)
> Apple Mail tends to send with the multipart "related" headers mentioned in bug
> #351224 , so this is likely to be the same issue

I could not detach attachments from an Apple Mail message.  While this has supposedly been fixed in Bug #351224, I guess it hasn't made its way into Thunderbird, or the fix did not work in my case.  An easy fix is to change the multipart headers to read "multipart/mixed".

Fix procedure:
1. Install the Thunderbird add-on TB_Header_Tools_0.7.1-tb3.xpi from http://forum.addonsmirror.net/index.php?showtopic=1906&st=0&p=38684&hl=TB%20header%20tools&fromsearch=1&#entry38684.
2. Highlight the message from which you wish to detach attachments.
3. Click on the Message menu, then the option "Change Header Details".
4. Click the button "Edit Full Source".
5. Find the line in the header beginning with "Content-Type: multipart/".  In my case, this line began with "Content-Type: multipart/alternative;"
6. This phrase should read "Content-Type: multipart/mixed;"
7. Click the OK button.
8. Detach your attachments.
(In reply to comment #24)
> (In reply to comment #12)
> > Apple Mail tends to send with the multipart "related" headers mentioned in bug
> > #351224 , so this is likely to be the same issue
> 
> I could not detach attachments from an Apple Mail message.  While this has
> supposedly been fixed in Bug #351224, I guess it hasn't made its way into
> Thunderbird, or the fix did not work in my case.

The fix is in the Miramar 3.3 alpha builds and will go into the version of Thunderbird based on those builds.
You need to log in before you can comment on or make changes to this bug.