firefox stops everything while 'file-selection'-dialog for <input type="file" /> fields

RESOLVED FIXED in Firefox 3 beta4

Status

()

Firefox
Shell Integration
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Benjamin Schulte, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Firefox 3 beta4
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

If you click on a 'Browse' button from an INPUT-field (type:file) the file-selection dialog opens. While this, firefox won't do anything and the whole application waits for the dialog to be closed.

Problem especially is mad while running a flash in a different tab streaming music/videos.

Reproducible: Always

Steps to Reproduce:
1. Stream a music-video using flash (youtube.com)
2. Open a different tab containing a file-upload formular (phpmyadmin, import-sql in my case)
3. Clicked on "browse" to select a file - 'file select' window opened
Actual Results:  
The streamed music in the parallel running tab (.flv video stream) stopped running. Also all tabs will stop everything like JavaScript or loading/displaying content.

Expected Results:  
The flash shouldn't stop. Maybe even the browser should still be able to be used at all. Maybe someone follows a tutorial and wants to check which file he has to upload.

I don't know if this problem is limited to windows. But for me the solution for this problem seems to be a full replacement of the Windows-API-call, finding an alternate method for file selection or running the call in a parallel thread.
(Reporter)

Comment 1

10 years ago
Should also note that I only tried it running the newest Firefox 3 Beta.
Dupe of bug 191691 (which is still UNCO)?

Comment 3

10 years ago
I don't think he is asking for the dialog to be non-modal, just that
events aren't processed.  Bug 389931 should fix that.
Depends on: 389931
Tested with Flash movie on YouTube, (per steps):


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.13pre) Gecko/2008030203 BonEcho/2.0.0.13pre] (nightly) (W2Ksp4)

FF v2 does not have this bug,
then it's not a bug 257121 duplicate.


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008022604 Minefield/3.0b4pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre] (nightly) (W2Ksp4)

R.Fixed, by bug 389931.
(Assuming it was a bug 326723 regression.)
Blocks: 326273, 381699
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: regression
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta4
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.