Quotation characters for different languages should be used in <Q> elements

VERIFIED DUPLICATE of bug 16206

Status

()

P3
enhancement
VERIFIED DUPLICATE of bug 16206
19 years ago
19 years ago

People

(Reporter: matt, Assigned: attinasi)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Build 2000060520, Linux 2.2.14, RedHat 6.1, i686

The following code:

<p lang="fr"><q>Qu'est-ce que c'est que <q>l'amour</q>?</q></p>

does not render the Q tags as French, even though it correctly renders
&laquo; and &raquo; (however, I have no Central European fonts installed).

This is a specific case from the generic bug41368 (which should be confirmed).

Comment 1

19 years ago
I'm not sure about this.
->Parser
Assignee: asa → rickg
Component: Browser-General → Parser
QA Contact: doronr → janc

Comment 2

19 years ago
oh, i see how this is supposed to work now (read spec on <q> element at 
http://www.w3.org/TR/REC-html40/struct/text.html#edef-Q)

confirming, will attach testcase in a moment
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

19 years ago
Created attachment 9768 [details]
bad rendering testcase

Updated

19 years ago
Keywords: testcase

Comment 4

19 years ago
Forwarding to the best style guy in San Diego. I think we're actually doing the 
right thing here. marc?
Assignee: rickg → attinasi
(Assignee)

Comment 5

19 years ago
HTML spec says:
"User agents should render quotation marks in a language-sensitive manner (see 
the lang attribute). Many languages adopt different quotation styles for outer 
and inner (nested) quotations, which should be respected by user-agents."

Note the *should* and the lack of a *must* in the spec...

So, we are not required to but *should* automatically handle quotes for 
supported languages. The easiest way to do this is probably via the style 
system. We already support the quotes property, so we could create rules in 
html.css like:

q[lang|='fr']{
 quotes: '<<' '>>' '<' '>';
}
Q[lang|='ge']{
 quotes: \2039 \203A \AB \BB;
}

or whatever the correct values are (I made those up).

Currently, we require the document author to provide the quote rules. I'll 
attach a testcase showing how an author can specify the quote characters 
themselves right now. Accepting as an enhancement request. 

If somebody can provide a listing of the correct quote characters for supported 
languages then getting them in should be very easy - figuring out the correct 
quote characters is the hard part here.
Severity: normal → enhancement
Status: NEW → ASSIGNED
Component: Parser → Style System
OS: Linux → All
Hardware: PC → All
Summary: Lang attrib doesn't work with Q tag → Quotation characters for different languages should be used in <Q> elements
Target Milestone: --- → M20
(Assignee)

Comment 6

19 years ago
Created attachment 9805 [details]
Testcase illustrating how to specify the quote characters yourself
(Assignee)

Comment 7

19 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: M20 → Future

*** This bug has been marked as a duplicate of 16206 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 9

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.