"ASSERTION: Shouldn't be observing anymore" removing 'ref' attribute

VERIFIED FIXED in mozilla1.9beta4

Status

()

Core
XUL
P1
normal
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
mozilla1.9beta4
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 303632 [details]
testcase

Loading the testcase triggers:

###!!! ASSERTION: Shouldn't be observing anymore!: '!mObservedDocument', file /Users/jruderman/trunk/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp, line 240

This assertion was added by bent in bug 416939.
Created attachment 304264 [details] [diff] [review]
Fix call chain, v1

This makes sure that we always remove the observer properly and consolidates the calls to the observer service. I just removed the warning about the null document because it doesn't seem to matter.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #304264 - Flags: review?(jst)
Flags: blocking1.9?
Target Milestone: --- → mozilla1.9beta4
(In reply to comment #1)
> I just removed the warning about the null document

Er, no I didn't. Different bug.

Updated

10 years ago
Attachment #304264 - Flags: superreview+
Attachment #304264 - Flags: review?(jst)
Attachment #304264 - Flags: review+

Updated

10 years ago
Flags: blocking1.9? → blocking1.9+
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Priority: -- → P1
Resolution: --- → FIXED
Duplicate of this bug: 417430
(Reporter)

Comment 5

10 years ago
Crashtest checked in.
Flags: in-testsuite+
verified fixed using the testcase and  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050621 Firefox/3.0pre - no assertion on testcase

--> Verified fixed
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.