All users were logged out of Bugzilla on October 13th, 2018

Border-style dotted or dashed not rendered correctly

VERIFIED DUPLICATE of bug 417543

Status

()

VERIFIED DUPLICATE of bug 417543
11 years ago
11 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 303765 [details]
Actual results in rv:1.9b4 build 2008021602 vs expected results in Firefox rv:1.8.1.12 build 20080201

Setting dynamically border-style to dotted (or dashed) is not rendered for each 4 sides. Border-bottom and border-left are rendered as solid, not as dotted (or dashed).

Steps to reproduce
------------------

1- Load provided URL
2- Set Style to dotted in the form

Actual results and expected results:
See attachment

Reproducible in Seamonkey 2.0a1pre rv: 1.9b4pre build 2008021602

Note:
- I searched for a duplicate and did not find one specifically stating the actual versus expected results
- Component set to Layout: please reset accordingly if this is wrong
- Adding regression keyword
(Reporter)

Comment 1

11 years ago
This bug also happens with outline borders.

Steps: 
1- load http://www.gtalbot.org/DHTMLSection/
2- focus a link

Involved stylesheet ( http://www.gtalbot.org/Stylesheets/StartSection.css ) has:

a:focus, button:focus, input:focus
		{
		outline: 2px dotted black;
		}

and you'll see that left outline border and bottom outline border are solid, not dotted.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417543
(Reporter)

Comment 3

11 years ago
Marking as VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.