drawing problems with overlapping iframes

VERIFIED DUPLICATE of bug 43410

Status

()

Core
Layout: HTML Frames
P3
normal
VERIFIED DUPLICATE of bug 43410
18 years ago
17 years ago

People

(Reporter: violaine.lebeaupin, Assigned: Eric Pollmann)

Tracking

({testcase})

Trunk
Future
x86
Windows 95
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DIGbug, PDT+, no ETA)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I try write a iframe on a iframe. It works. However if I display a window
(in Windows 95) then display mozilla's window, my second iframe isn't
visible.

My case test :
<HTML>
 <SCRIPT>
  function init()
  {
   window.top.document.getElementById("div2").style.left = 370;
   window.top.document.getElementById("div2").style.top = 80;
   window.top.document.getElementById("div2").style.visibility = "visible";
  }
 </SCRIPT>
 <BODY onLoad="init()">
  <DIV>
   <IFRAME style="width:100%; height:427" FRAMEBORDER=0
src="bonjour.html"></IFRAME>
  </DIV>
  <DIV ID="div2" STYLE='POSITION: absolute; VISIBILITY: hidden;'>
   <IFRAME WIDTH=410 HEIGHT=25 FRAMEBORDER=1 MARGINHEIGHT=0 MARGINWIDTH=0
src="coucou.html"></IFRAME>
  </DIV>
 </BODY>
</HTML>

Comment 1

18 years ago
confirming (2000 060408, win98).  the iframes seem to be fighting over the 
right to draw in the overlapping area, creating a flicker while loading, a race 
condition (try reloading the testcase several times), and the potential for 
bugs that show up only after the area is covered by another window.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Summary: problems when an iframe covered another iframe → drawing problems with overlapping iframes

Comment 2

18 years ago
Created attachment 9804 [details]
testcase based on reporters (three html files, zipped)
(Assignee)

Comment 3

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future

Comment 4

18 years ago
The another side effect of this rendering problem is that z-index order of 
iframes are totally disregarded and they are arbitrarily drawn. To be more 
clear, if you overlap 10 iframes giving them the z-index parameter, then open 
another window over mozilla's and raise mozilla's window again, all the z-index 
order of the frames will be disregarded while redrawing of the page. It sounds 
like an easy fix, but I do not want to make incorrect assumptions. This bug 
will be a very bothersome bug for DOM programmers. On the other hand, in most 
cases iframe's z-index is not picked correctly. It is sometimes completely 
disregarded especially when I am dynamically creating iframes.

Comment 5

17 years ago
see also bug 43410 (z-index of iframes not honored)

Comment 6

17 years ago
QA Contact update
QA Contact: petersen → amar

Comment 7

17 years ago
Marking DIGbug, PDT+.  Blocker for DIG.
Whiteboard: DIGbug, PDT+

Comment 8

17 years ago
eric, any chance at nailing this one?
Whiteboard: DIGbug, PDT+ → DIGbug, PDT+, no ETA
(Assignee)

Comment 9

17 years ago
So far I've not had any luck.  FWIW, this really is the same problem as in bug 
43410 (also DIG+, and with more history) so I'm marking it a dup.

*** This bug has been marked as a duplicate of 43410 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
 Verified that this is a dupe of Bug# 4310.. Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.