Signature with image in it causes hang in compose

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: joe, Unassigned)

Tracking

({hang})

Bug Flags:
in-testsuite ?
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12
Build Identifier: version 2.0.0.6 (20071022)

Setting a signature with an image it in causes the sending process to hang at the attaching stage.

This also occurs on the windows version

Reproducible: Always

Steps to Reproduce:
1. Attach signature with image
2. Write email
3. Press send
Actual Results:  
Hangs at attaching image stage

Expected Results:  
Email sent

Occurs on both windows and linux
(Reporter)

Comment 1

11 years ago
Created attachment 304000 [details]
Email signature that causes problem
(Reporter)

Comment 2

11 years ago
I tried to find a relevant bug, but there were none quite the same. This occurs even if the email is not saved as a draft etc.
Doesn't hang for me, on linux - version 3.0a1pre (2008021803).

No pic though, as it links to file:///home/joe/Desktop/hcclogo.jpg
(Reporter)

Comment 4

11 years ago
It also links to cid:image001.gif@01C85F57.0F3341B0 as it was copied from an email sent from someone else. Removing this, makes it work again on linux. As yet untested on windows, but I assume the same fix will work.

Sorry for the noise.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 5

11 years ago
Reopening with lower severity given it sounds like it's edge-casey.
Severity: major → minor
Status: RESOLVED → UNCONFIRMED
Keywords: hang
Resolution: INVALID → ---
Version: unspecified → 2.0

Comment 6

10 years ago
I've noticed this bug a few times times as well in Thunderbird (2.0.0.16) on Windows. When I send the e-mail there is a status progress window that says "attaching" which never goes away. It's impossible to save the e-mail as a draft too because I get the same "attaching" message.

I only now figured out the problem was with the image in a signature of someone who wrote something in the mail conversation and when I removed it I could send it right away. However I couldn't reproduce the problem by doing the same reply again. Very strange.

Comment 7

10 years ago
Fails v1.5.0.14 and v2.0.0.13pre.  However WFM v3** but I haven't found what fixes it.  bug 270380 supposedly fixed something like this in 2.x - but clearly didn't fix this issue since it fails in .13pre.  

This is a major bug and it's shocking there aren't more reports, unless it doesn't happen for all users of v2. Does this happen for only *some* types of image links? or all?  

And does this work for you with http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
 - if it does work then we'll => WFM 

Please sort out what should be duped to what and confirmed/closed. And whether you attempt to get it fixed in v2. 

related/dupes:
 bug 368151 - Signatures with image  
 Bug 215665 -  mail with signature containing an image URL can not be sent - image is not found 
 270380 -  Local image files in HTML signature file on top don't get attached in replies
 query http://tinyurl.com/5llxv7

** WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081016 Shredder/3.0b1pre

Setting flags so we follow up with this for QA.
Severity: minor → major
Flags: in-testsuite?
Flags: in-litmus?
Summary: Signature with image in it causes hang → Signature with image in it causes hang in compose

Comment 8

10 years ago
Created attachment 345376 [details]
cert evolution

Comment 9

10 years ago
(In reply to comment #7)
> This is a major bug and it's shocking there aren't more reports, unless it
> doesn't happen for all users of v2. Does this happen for only *some* types of
> image links? or all?  

I'm seeing frequent reports of images in signatures arbitrarily causing a stall during sending (these are local files, not remote images, also Windows) in the MozillaZine support forums. I'll try to motivate somebody to test this on a trunk build and report here if this is reproducible.

Comment 10

10 years ago
I have experienced this problem as well - both on 2.0.0.18 on Windows and 2.0.0.16 on Linux. The only problem is that it isn't consistent. The image would refuse to attach properly (hanging on the "Attaching ..." dialog box) - then I restarted Thunderbird - and it worked properly. The steps I followed were:

1. Crete a new mail message, place some text and html formating inside, insert and image. Save as an HTML file (from Thunderbird) to be used as signature file. Checked that path for the image has been stored as absolute (in the html code).
2. Go into account settings in Thunderbird and set the file above as signature file.
3. When attempting to create a new mail message - the behaviour varies - sometimes the image doesn't display (during composing), sometime it hangs during sending (with the 'Attaching' dialog box). I have checked, and it seems that although the path is correct in the html signature file, when Thunderbird parses and includes the html code from the signature file into the new message - it somehow ends up stripping or amending the path. Sometimes the path shows as "http://image_filename.jpg", other times it is just "image_finename.jpg". It seems to make it relative (to something, not even sure what), and that's why it seems to have trouble attaching it and sending it away. The problem is that it is not consistent.

Actually - I have just tried it again - and there seems to be (possibly) a solution to it. It seems that if one creates the signature file, amends the signature settings and tests the signature all in one session (without restarting Thunderbird) - it is much more likely for this bug to occur. If Thunderbird is restarted after making the signature file and amending signature settings, and then the testing is done - it seems to be working. At least my testing seems to point in this direction. Maybe this explains why only certain people are experiencing it - the ones in a hurry :-)

Could someone else please test this and see if it is reproducible this way?

Comment 11

10 years ago
I confirm that the "Attaching..." hang occurs on Thunderbird 2.0.0.18 (20081105) on Windows XP SP2. As described above in comment #10, restarting Thunderbird after changing the signature settings resolved my symptoms.

I followed the wiki instructions for creating a signature with an image as follows: composing the signature as a message, inserting a local image, saving the message as HTML, then Tools -> Account Settings and Choose the saved HTML for the "Attach this signature" setting. Then confirm the changes by clicking OK.

Immediately composing a message thereafter, the new signature displayed properly in the composition window. Upon sending, Thunderbird stalled on "Attaching..."  Restarting Thunderbird resolved the problem, allowing the image to be attached and the message to be sent.
->WFM since we seem to agree it's not problem on tb3.
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → WORKSFORME

Comment 13

6 years ago
This issue still present in the latest version of Thunderbird under Windows 7 and XP.

Y experienced the same issue in 20 computers with Windows xp (in the office) and in my personal computer with Windows 7. Version 13.0.1.

It's very annoying and can be reproduced easily. Just sending and email with an image in the signature, and trying to answer to this first email. 
It's a very common scenario since a lot of people uses images in the signature.

Comment 14

6 years ago
(In reply to jpablo from comment #13)
> This issue still present in the latest version of Thunderbird under Windows
> 7 and XP.

THis report has been closed for over 3 years. So whatever you are seeing is a new(ish) issue, and we don't reopen the old bug for that. In short, please file a new bug.
You need to log in before you can comment on or make changes to this bug.