Last Comment Bug 418290 - SEC_ERROR_REVOKED_CERTIFICATE message has typo
: SEC_ERROR_REVOKED_CERTIFICATE message has typo
Status: RESOLVED FIXED
[good first bug]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla13
Assigned To: Mark Capella [:capella]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 13:15 PST by Kyungjoon Lee
Modified: 2012-02-09 10:36 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Change wording from can not to cannot in netError.dtd file (1.13 KB, patch)
2009-07-29 08:41 PDT, Tommy
kaie: review-
Details | Diff | Splinter Review
Change wording from can not to cannot in netError.dtd file (1.76 KB, patch)
2009-12-31 05:57 PST, Bas Hickendorff
kaie: review+
Details | Diff | Splinter Review
five files changed ... old typos fixed (6.79 KB, patch)
2012-02-08 01:24 PST, Mark Capella [:capella]
dao+bmo: review+
Details | Diff | Splinter Review

Description Kyungjoon Lee 2008-02-18 13:15:31 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

The message for SEC_ERROR_REVOKED_CERTIFICATE has

> The page you are trying to view can not be shown [...]

This should say "cannot", not "can not".



Reproducible: Always

Steps to Reproduce:
1. Try to get to a site with a revoked certificate
2. Observe error message
3. Notice typo
Actual Results:  
The page you are trying to view can not be shown [...]

Expected Results:  
The page you are trying to view cannot be shown [...]
Comment 1 Kyungjoon Lee 2008-02-18 13:49:08 PST
Oh well, the source has "can not" all over the place, but

http://www.askoxford.com/asktheexperts/faq/aboutspelling/cannot?view=uk

AskOxford says "can not" is also acceptable (although it isn't for me).
Comment 2 Kai Engert (:kaie) 2008-02-19 00:12:33 PST
The "can not be shown" string is not contained in the security portion of the code, but in file netError.dtd, which is contained in 3 places:
- firefox
- camino
- dom

I'm changing the component of this bug to Firefox.
If any change is made, the other products should follow.

However, I think, if both forms "can not" and "cannot" are equally allowed, and if the source already mixes it (as you say), maybe we should not bother...?
Comment 3 Johnathan Nightingale [:johnath] 2008-02-19 06:15:27 PST
As Kyungjun Lee points out, both forms are technically acceptable, but if someone wanted to build an omnibus patch that harmonized our strings here, that would be nifty.
Comment 4 Kyungjoon Lee 2008-02-19 10:14:39 PST
However, AskOxford.com is a bit vague, and other sources which discourage "can not" (except in emphasis of "not") are readily found.

I'll see what I can do.
Comment 5 Ari Aaron 2008-06-26 19:34:15 PDT
http://lxr.mozilla.org/mozilla1.8.0/search?string=cannot
http://lxr.mozilla.org/mozilla1.8.0/search?string=can%20not

It seems both are used, although cannot is much more common. can not is mostly in comments.
Comment 6 Tommy 2009-07-29 08:41:57 PDT
Created attachment 391348 [details] [diff] [review]
Change wording from can not to cannot in netError.dtd file

This is a patch file created to change "can not" to "cannot" in netError.dtd file.  This is my first bug and I would like to experience the process of creating and submitting patches.
Comment 7 Kai Engert (:kaie) 2009-08-20 06:29:41 PDT
Tommy, thank you very much for getting started to work on Mozilla!

As I suggested in comment 2, I would prefer a "complete" patch.
That is, due to technical reasons, this very same string is currently used in at least 3 areas in the Mozilla source tree.

Would you be able to produce a patch that changes all three occurrences?
I think all 3 files are named netError.dtd. One of them might not be in the standard Firefox tree, but live in a Camino directory (a mac browser based on Firefox).
Comment 8 Kai Engert (:kaie) 2009-08-20 06:30:02 PDT
Comment on attachment 391348 [details] [diff] [review]
Change wording from can not to cannot in netError.dtd file

r-

Patch is correct but incomplete.
Comment 9 Axel Hecht [pto-Aug-30][:Pike] 2009-12-31 05:32:51 PST
For whatever you fix, can you do a corresponding query on the l10n mxr's to see which localizations should get follow-up bugs filed? 1.9.2 branch might be good enough, if there are not extra entries for SeaMonkey/Thunderbird (that's on 1.9.1)
Comment 10 Bas Hickendorff 2009-12-31 05:57:50 PST
Created attachment 419677 [details] [diff] [review]
Change wording from can not to cannot in netError.dtd file

This is a patch for netError.dtd in /browser and in /dom. Not in Camino, because Camino is not in mozilla-central. On irc #developers, Pike advised opening a seperate bug for this issue in Camino.

This is my first patch, and although it is a very simple one, I would welcome all feedback, to get familiar with the patching process at mozilla.
Comment 11 Axel Hecht [pto-Aug-30][:Pike] 2009-12-31 06:04:34 PST
I see "can not" to "cannot", should the same thing happen for "could not" to "couldn't"?
Comment 12 Dão Gottwald [:dao] 2009-12-31 07:47:49 PST
(In reply to comment #11)
> I see "can not" to "cannot", should the same thing happen for "could not" to
> "couldn't"?

That's a different story, as far as I know... "could not" is formal whereas "couldn't" is considered informal in writing.
Comment 13 Bas Hickendorff 2010-01-01 14:54:56 PST
(In reply to comment #9)
> For whatever you fix, can you do a corresponding query on the l10n mxr's to see
> which localizations should get follow-up bugs filed? 1.9.2 branch might be good
> enough, if there are not extra entries for SeaMonkey/Thunderbird (that's on
> 1.9.1)

I checked, and there are several (see: http://mxr.mozilla.org/l10n-mozilla1.9.2/search?string=can+not&find=netError.dtd)

The file netError.dtd with "can not" is present in the following folders in the l10n branch:
eo
en-GB
ta
or
oc
ta-LK
af
pa-IN
x-testing

I guess since they are all in the same branch, there can be one bug filed to fix all of them? If so, I will file that bug and create a patch for them. Is this indeed the way to go?

When we fix this bug for Camino as well, is everything then covered, or should other cases like "couldn't" be taken care of as well? My feeling is that "could not" is fine, but I'm not a native English speaker, so I'm not in the best position to have an opinion on that.
Comment 14 Johnathan Nightingale [:johnath] 2010-01-04 05:53:41 PST
(In reply to comment #13)
> I guess since they are all in the same branch, there can be one bug filed to
> fix all of them? If so, I will file that bug and create a patch for them. Is
> this indeed the way to go?
> 
> When we fix this bug for Camino as well, is everything then covered, or should
> other cases like "couldn't" be taken care of as well? My feeling is that "could
> not" is fine, but I'm not a native English speaker, so I'm not in the best
> position to have an opinion on that.

(In reply to comment #12)
> (In reply to comment #11)
> > I see "can not" to "cannot", should the same thing happen for "could not" to
> > "couldn't"?
> 
> That's a different story, as far as I know... "could not" is formal whereas
> "couldn't" is considered informal in writing.

I must say it warms my heart to see three non-native English speakers debating the relative propriety of could vs. couldn't; you would all fit in quite well in the Toronto office, where we spend more time than is strictly required teasing apart the vagaries of this stupid language.

I agree with Dao - "Could not" doesn't look wrong to the eye the way "can not" does. Let's fix "can not" and move along.  Thanks for the patch, Bas (and earlier, Tommy).
Comment 15 Bas Hickendorff 2010-01-21 02:26:01 PST
I filed bug 541055 for fixing this in Camino (with patch), and bug 541053 for fixing this in l10n (patch coming when my question there is answered).
Comment 16 Axel Hecht [pto-Aug-30][:Pike] 2010-01-21 03:40:31 PST
http://l10n.mozilla.org/dashboard/bugzilla.html can help you with filing the various bugs. Use %(loc)s in any form field where you need the locale code, i.e.

[%(loc)s] typo...

for the summary and in the comment, http://mxr.mozilla.org/l10n-mozilla1.9.2/search?string=can+not&find=%(loc)s/.*/netError.dtd to generate a good mxr link for each locale.

For x-testing, there's no bug needed, that's just our test data to trigger builds every now and then, nobody is ever getting real builds off of that.
Comment 17 Bas Hickendorff 2010-01-24 04:51:22 PST
All the affected localizations have a bug now, and all of them have a patch. What should happen now?
Comment 18 Axel Hecht [pto-Aug-30][:Pike] 2010-01-24 05:30:07 PST
Now it's up to the localizers to pick up those fixes and get them into released bits.

I un-CC-ed myself on purpose, fwiw, no need for me (and the folks that watch me) to get bugmail on those.
Comment 19 Bas Hickendorff 2010-01-24 05:48:43 PST
Okay, thanks, and sorry for the spam on those other bugs :)
Comment 20 Kai Engert (:kaie) 2010-06-08 07:11:36 PDT
Comment on attachment 419677 [details] [diff] [review]
Change wording from can not to cannot in netError.dtd file

r=kaie
Comment 21 Mark Capella [:capella] 2012-02-07 23:00:30 PST
   I'm reviewing the [Good first bugs] and wonder if this old item is resolvable? 

   I also found two additional references to netError.dtd files with "can not" that don't appear in the patch:

      b2g\locales\en-US\chrome\overrides
      mobile\locales\en-US\overrides
Comment 22 Dão Gottwald [:dao] 2012-02-08 01:00:54 PST
Full list of affected files:

http://mxr.mozilla.org/mozilla-central/search?string=can+not&find=&filter=properties|dtd
Comment 23 Mark Capella [:capella] 2012-02-08 01:24:49 PST
Created attachment 595345 [details] [diff] [review]
five files changed ... old typos fixed

Added the properties file to the four DTD files
Comment 24 Dão Gottwald [:dao] 2012-02-08 01:35:10 PST
Comment on attachment 595345 [details] [diff] [review]
five files changed ... old typos fixed

Thanks!
Comment 26 Ed Morley [:emorley] 2012-02-09 10:36:30 PST
https://hg.mozilla.org/mozilla-central/rev/3696e562509d

Thank you for the patch! :-)

Note You need to log in before you can comment on or make changes to this bug.