tell image rendering to use SOURCE instead of OVER

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: vlad, Assigned: vlad)

Tracking

({perf})

Trunk
x86
All
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 304308 [details] [diff] [review]
use OPERATOR_SOURCE when possible

Image rendering can use the SOURCE operator instead of OVER in a bunch of cases; let's do that.
Flags: blocking1.9+
Attachment #304308 - Flags: review?(pavlov)

Updated

10 years ago
Attachment #304308 - Flags: review?(pavlov) → review+
How does code with OPREATOR_OVER compile?
(In reply to comment #1)
> How does code with OPREATOR_OVER compile?

I'm not sure what you mean?
oh, the typo; I edited the patch manually because I caught that check that was needed.. then fixed it when I went to compile.  so yeah, fixed in my local tree ;)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
This optimization is not correct for RGB24 unless we are sure that we will never sample outside of the image area. When EXTEND_NONE (or the xserver doesn't support PAD?) and the source is transformed it's hard to be sure of that.

I see symptoms of this when zoomed in on the mozilla.org page in fennec: There are grey/black borders that appear/disappear around the images.
Jeff, you reverted this patch and it fixed the fennec bug you saw, right?
Yes, it did.
Jeff, did you file a bug on that? I've hit that exact issue just now.
I don't recall filing one, but this quite a while ago.
However, there is bug 566283 which is a recent regression.
Depends on: 566283
You need to log in before you can comment on or make changes to this bug.