Last Comment Bug 566283 - Rendering artifacts (extra borders/black,grey lines) around images at certain zoom levels
: Rendering artifacts (extra borders/black,grey lines) around images at certain...
Status: RESOLVED WORKSFORME
: regression, testcase
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jeff Muizelaar [:jrmuizel]
:
:
Mentors:
: 566771 (view as bug list)
Depends on: 562746
Blocks: 418494 542605 577837
  Show dependency treegraph
 
Reported: 2010-05-17 01:13 PDT by Nickolay_Ponomarev
Modified: 2010-12-13 16:13 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
betaN+


Attachments
use EXTEND_PAD on mac (1.00 KB, patch)
2010-12-11 22:23 PST, Joe Drew (not getting mail)
no flags Details | Diff | Splinter Review

Description Nickolay_Ponomarev 2010-05-17 01:13:10 PDT
1. Load http://www.google.com/intl/en_ALL/images/srpr/logo1w.png
2. Check the image appearance at different zoom levels:

(number of zoom-ins/outs from 100% zoom)
-5 horizontal line below the image
-4 lines at the bottom and right of the image
-3 line at the right
-2 ok
-1 line at the bottom
100%  - ok
+1 ok
+2 line at the right
+3 ok
+4 right, bottom borders
+5 grey line at the bottom
+6 ok
+7 right,bottom
+8 ok

This happens only on Mac for me (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100516 Minefield/3.7a5pre)

This is a regression from bug 542605 (verified by backing out locally).

(and in case the build system failed me, testing with nightlies shows this regression range:
works: 2010-04-26-03  http://hg.mozilla.org/mozilla-central/rev/2968d19b0165
fail:  2010-04-27-03  http://hg.mozilla.org/mozilla-central/rev/29a6a85fab8e )
Comment 1 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2010-05-17 08:31:40 PDT
That regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2968d19b0165&tochange=29a6a85fab8e

The cairo update seems like the most likely cause, but there are a bunch of other possibilities.
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2010-05-17 08:32:32 PDT
Er, sorry, I missed the line in comment 0 that said this is confirmed to be a regression from the cairo update.
Comment 3 Josh Aas 2010-05-25 22:40:20 PDT
Blocking 1.9.3 beta1, serious visual regression which is easy to reproduce.
Comment 4 Jeff Muizelaar [:jrmuizel] 2010-05-26 16:00:59 PDT
*** Bug 566771 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Muizelaar [:jrmuizel] 2010-05-26 16:08:52 PDT
I believe this comes from EXTEND_NONE being fixed in the cairo quartz backend.
Switching to EXTEND_PAD could fix this.
Comment 6 Joe Drew (not getting mail) 2010-06-14 12:34:30 PDT
Needs to hit _a_ beta, not necessarily _this_ beta.
Comment 7 Jeremie Patonnier :Jeremie 2010-06-16 13:08:43 PDT
I confirm the bug on Linux With Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a6pre) Gecko/20100616 Minefield/3.7a6pre

But with some different behaviors:

(number of zoom-ins/outs from 100% zoom)
-5 ok
-4 lines at the bottom and right of the image
-3 line at the right
-2 ok
-1 line at the bottom
100%  - ok
+1 ok
+2 ok
+3 ok
+4 right, bottom borders
+5 ok
+6 ok
+7 ok
+8 ok
Comment 8 Smokey Ardisson (offline for a while; not following bugs - do not email) 2010-06-16 22:00:28 PDT
Isn't this bug 567370 comment 0, or vice-versa?
Comment 9 Oleg Romashin (:romaxa) 2010-06-16 23:37:50 PDT
this problem will be fixed after cairo update 562746...
Problem not reproducible with patch for next cairo update bug...

Current cairo is broken, and causing not only rendering problems but also stability issues like 569669
Comment 10 Zack Weinberg (:zwol) 2010-06-29 11:12:29 PDT
See also bug 468496.
Comment 11 Markus Stange [:mstange] 2010-07-07 17:42:03 PDT
I think this is exactly the problem mentioned in bug 418494 comment 4. Removing the optimization fixes the problem.
Comment 12 Joe Drew (not getting mail) 2010-12-11 22:23:08 PST
Created attachment 497111 [details] [diff] [review]
use EXTEND_PAD on mac

Josh, if you can still reproduce this, can you apply this patch and see if it fixes the bug? It makes us use EXTEND_PAD correctly on OS X.
Comment 13 Josh Aas 2010-12-12 07:57:29 PST
Comment on attachment 497111 [details] [diff] [review]
use EXTEND_PAD on mac

I can't reproduce the problem on trunk and Mac OS X 10.6. I won't have access to a 10.5 box until next week.
Comment 14 Nickolay_Ponomarev 2010-12-12 12:34:23 PST
I can't reproduce on 10.5 with steps from comment 0 anymore...
Comment 15 Zack Weinberg (:zwol) 2010-12-13 16:13:31 PST
IMNSHO the patch should be applied even though the original problem is unreproducible, as it makes a special case go away.

Note You need to log in before you can comment on or make changes to this bug.