want topcrash reports that allow telling which crashes are fixed

RESOLVED FIXED

Status

Socorro
General
P2
major
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: dbaron, Assigned: ozten)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
It's very hard to tell from http://crash-stats.mozilla.com/topcrasher/bybranch/1.9 which crashes have been fixed recently, for two reasons:

 1. its definition of "the last 2 weeks" is the date of the crash, not the date of the build

 2. it doesn't show any notion of change-over-time

I'd like a report that allows eyeballing whether crashes have been fixed, much like http://talkback-public.mozilla.org/reports/firefox/FF2x/FF2x-topcrashers.html (which isn't all that useful on branch, since the number of users is so low, but was quite useful when it was generated for trunk).  I'm not saying it needs to be exactly the same UI.

However, if we want to do a strong push on topcrashes between now an Firefox 3 final (or especially if we do so between release candidates), we want to be able to get fixes in and get quick feedback within days whether the fixes did or didn't work, and whether the fixes happened to have fixed additional crash signatures that we didn't expect them to fix.
(In reply to comment #0)
>  1. its definition of "the last 2 weeks" is the date of the crash, not the date
> of the build

I talked this out with morgamic previously. I thought it was filed, but I can't seem to find it. We should definitely be doing this for trunk but not for release builds.

>  2. it doesn't show any notion of change-over-time

morgamic was working on spark lines for this. They'd appear at or near the end on the topcrash pages.

Comment 2

10 years ago
going to suggest that this gets moved up to p2.  we are using a wiki page to help track this summary info right now ( http://wiki.mozilla.org/QA/Topcrashes ) , but having crash reporter and bugzilla connected would make things a lot more efficient.

Priority: -- → P2
Depends on: 420997
Target Milestone: --- → 0.6

Updated

10 years ago
Duplicate of this bug: 441287
Target Milestone: 0.6 → ---
This is the UI portion of bug 411397
Assignee: nobody → ozten.bugs
Depends on: 411397

Comment 5

8 years ago
I think this is done with the graphs next to each signature on e.g.
http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.6.4

(Reopen if I'm wrong, or this is insufficient)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.