AUS: Update XML File Malformed (200) error on the first try

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: adriank, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; PL; rv:1.8.1.12) Gecko/20080201 MultiZilla/1.8.3.4e SeaMonkey/1.1.8
Build Identifier: 

It looks like on the first try to check for updates, SeaMonkey produces an "AUS: Update XML File Malformed (200)" error.
Checked on all three platforms.
A second try always work.

Reproducible: Always

Steps to Reproduce:
1. Start a SeaMonkey nightly
2. Check for updates
3. See the error
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
it looks like the URL maybe points to the en-US Version, because after trying to update the Polish version I tried the same with German and French versions, and there the update was downloaded in one second. 
(Reporter)

Comment 2

11 years ago
sorry, the comment was not intended to this bug (and has nothing to do with it)...

Comment 3

11 years ago
I read that some Firefox users see such a message when using certain personal firewalls, could that be an issue for you?
(Reporter)

Comment 4

11 years ago
I don't think that this is the problem. Especially because I see this problem also in Linux and Mac OS X 10.5.
But something changed since Monday. On Sunday I could still reproduce this bug all the day every time I tried (at the FOSDEM room and in the hotel). But now that happens to me only from time to time... Have to investigate more...

Comment 5

11 years ago
OK, this looks like a SSL error. In the error console I see
Fehler: channel.securityInfo is null
Quelldatei: file:///mnt/mozilla/packages/seamonkey-2.0a1pre.de.linux-i686/seamonkey/components/nsUpdateService.js
Zeile: 102

From IRC:
<Mossop> Ah, bad ssl
<Mossop> KaiRo: Most likely the request is being redirected to an insecure url

When loading https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008022801/Linux_x86-gcc3/de/nightly/update.xml?force=1 manually, I get the warning box for loading an encrypted page containing unencrypted content!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

11 years ago
I was just informed that the warning box could be because of XML prettyprint CSS

Comment 7

11 years ago
Setting the app.update.log.Checker pref to true at least gives some info in the error console about what it's doing

Comment 8

11 years ago
looks like a package update on aus2-community solved this
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 9

11 years ago
Hmm, I saw this again when testing for bug 419258 today - interestingly, it only happens on the first try to do an update, and works fine when I just try a second time. I get the same error message in the console as in comment #5

Comment 10

11 years ago
It's not always the first time, but it happens intermittently.
Here are two Checker logs from the same build, first try succeeded though it found no new updates, second try failed with the security error:

Successful log:

*** Checker: update url: https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: update url: https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: update url: https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: checkForUpdates: sending request to https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: onLoad: request completed downloading document
*** Checker: Updates available: 0

Unsuccessful log:

*** Checker: update url: https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: update url: https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: update url: https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: checkForUpdates: sending request to https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008030401/Linux_x86-gcc3/de/nightly/update.xml?force=1
*** Checker: onError: error during load
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

11 years ago
http://mxr.mozilla.org/mozilla/source/toolkit/mozapps/shared/src/badCertHandler.js#50 is the line that fails with the security problem (badCertHandler.js get #included in nsUpdateService.js by the preprocessor), http://mxr.mozilla.org/mozilla/source/toolkit/mozapps/update/src/nsUpdateService.js.in#2062 is where it's called.

interestingly, we seem to pass the "https" test, so the channel does exist (actually the channel member of a XmlHttpRequest object), but we're unable to get the securityInfo from it.
Status: REOPENED → NEW

Comment 12

10 years ago
Now after bug 451164 we maybe might get a better error message. We probably should re-try with builds that have that patch.

Comment 13

10 years ago
I cannot reproduce this error at all in recent builds. Can anyone else? Else we should mark this WFM now.

Comment 14

10 years ago
No objection to my last comment has been registered in 9 months, so marking this as WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.