Last Comment Bug 419292 - Resizer / Grippy / Grippie present on maximized window
: Resizer / Grippy / Grippie present on maximized window
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Windows XP
-- normal with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 431688 432289 446632 456965 535107 (view as bug list)
Depends on: 472258
Blocks: 121150 440586
  Show dependency treegraph
 
Reported: 2008-02-24 05:35 PST by Steve England [:stevee]
Modified: 2010-04-06 09:46 PDT (History)
26 users (show)
mconnor: blocking‑firefox3-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Grippie present on maxmised window (172.99 KB, image/jpeg)
2008-04-30 02:54 PDT, Michael Mak
no flags Details
sizemode/windowState manual test (7.14 KB, application/vnd.mozilla.xul+xml)
2009-01-06 09:44 PST, Nickolay_Ponomarev
no flags Details

Description User image Steve England [:stevee] 2008-02-24 05:35:11 PST
The 'Restore Down/Maximize' button I refer to is the one that appears in the middle of the three icons at the top right of any Windows window, between the [_] (minimize) and the [x] (close) buttons.

1. Make sure your desktop has no open windows on it, and nothing docked to any side of your desktop.
2. New profile, start Firefox
3a. If Firefox starts maximized, press the 'Restore Down/Maximize' button at the top right of the window twice.
3b. If Firefox does not start maximized, press the 'Restore Down/Maximize' button at the top right of the window three times.
4. Firefox should now be maximized. Observe the bottom right of the firefox window.

Expected:
- No resizer grippy should be present because the window is maximized.

Actual:
- Resizer grippy present

Works: 20080122_2055_firefox-3.0b3pre.en-US.win32
Broken: 20080122_2130_firefox-3.0b3pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-01-22 20:55 and 2008-01-22 21:30 : 
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-01-22+20%3A55&maxdate=2008-01-22+21%3A30&cvsroot=%2Fcvsroot
Caused by bug 407201 it seems.
Comment 1 User image Peter van der Woude [:Peter6] 2008-02-24 11:16:24 PST
not only that, you can actually resize a maximized window using the grippy.
The state of the minimize/maximize button changes when you change the window with the grippy from maxed to another size
Comment 2 User image Mike Connor [:mconnor] 2008-02-26 09:17:30 PST
Doesn't seem like a blocker, doesn't seem harmful in our testing, if not 100% correct.
Comment 3 User image Geva Zeichner 2008-03-03 12:01:40 PST
I've noticed that when moving your focus out of the FF window and back to it - the gripper disappears again.
Comment 4 User image Michael Mak 2008-04-30 02:53:09 PDT
Can confirm all of the above with 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre ID:2008042906
Comment 5 User image Michael Mak 2008-04-30 02:54:03 PDT
Created attachment 318569 [details]
Grippie present on maxmised window
Comment 6 User image Kevin Brosnan 2008-05-05 12:27:16 PDT
*** Bug 432289 has been marked as a duplicate of this bug. ***
Comment 7 User image Kai Liu 2008-06-19 16:41:38 PDT
*** Bug 431688 has been marked as a duplicate of this bug. ***
Comment 8 User image Robert Johnston 2008-07-22 21:47:00 PDT
Essentially, what's happening here is that the attribute "sizemode" isn't changing to "maximized" when it happens. You can alt-tab away and alt-tab back and the value then changes, making the CSS rule(s) that depend on it work properly. What needs to happen is on maximize, update the "sizemode" attribute.
Comment 9 User image Ria Klaassen (not reading all bugmail) 2008-09-25 14:49:34 PDT
*** Bug 456965 has been marked as a duplicate of this bug. ***
Comment 10 User image Ria Klaassen (not reading all bugmail) 2008-09-25 14:50:17 PDT
*** Bug 446632 has been marked as a duplicate of this bug. ***
Comment 11 User image Ed Hume 2008-09-27 07:21:40 PDT
Perhaps an additional clue: when Forecastfox is set to appear at the right end of the status bar, the grippy (in the Maximized window mode) appears to the left of the Forecastfox elements, but to the right of all other statusbar elements. Using Forecastsfox's context selection of Options, then canceling, will make the grippy disappear. Resizing and maximizing will cause the grippy to again appear between the normal statusbar elements and Forecastfox.
Comment 12 User image Ben Lerner 2008-11-10 15:32:32 PST
Is bug 251599 at all related (i.e., would fixing this attribute fix full-screen too)?
Comment 13 User image Nickolay_Ponomarev 2009-01-06 09:44:17 PST
Created attachment 355604 [details]
sizemode/windowState manual test

This can be used to test how window.minimize(), maximize(), restore() calls and minimizing/maximizing the window manually affects window.windowState property and the sizemode attribute (the latter is used to determine visibility of the grippy).
Comment 14 User image Nickolay_Ponomarev 2009-02-03 11:13:26 PST
Please check with the next trunk nightly - should be fixed.
Comment 15 User image WildcatRay 2009-02-03 11:28:40 PST
I am not seeing this in build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090203 Minefield/3.2a1pre - Build ID: 20090203033842
Comment 16 User image u88484 2009-02-03 11:33:57 PST
(In reply to comment #15)
> I am not seeing this in build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.2a1pre) Gecko/20090203 Minefield/3.2a1pre - Build ID: 20090203033842

It is still there using the same build.  You have to click the restore down button and then click the maximize button (same button) then the grippy will still show on the maximized window.
Comment 17 User image WildcatRay 2009-02-03 11:47:14 PST
Kurt,

That is exactly what I did. However, it must be an add-on that is affecting things for my main-use profile. In using a plain, unadorned profile, the bug is still present.

Sorry about that.

(In reply to comment #16)
> (In reply to comment #15)
> > I am not seeing this in build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> > rv:1.9.2a1pre) Gecko/20090203 Minefield/3.2a1pre - Build ID: 20090203033842
> 
> It is still there using the same build.  You have to click the restore down
> button and then click the maximize button (same button) then the grippy will
> still show on the maximized window.
Comment 18 User image Nickolay_Ponomarev 2009-02-03 12:11:19 PST
This is windows-only regression. It never worked on at least Mac (not sure about linux).
Comment 19 User image alex_mayorga 2009-02-18 07:56:30 PST
Still happens in Shiretoko nightlies on Vista too
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090218 Shiretoko/3.1b3pre ID:20090218033015
Comment 20 User image Nickolay_Ponomarev 2009-02-19 01:28:49 PST
Bug 472258 was fixed on trunk (3.2) only, which should have fixed this issue.

comments 15&16 tested this on a build before the fix was checked in.
Comment 21 User image Micah Gersten 2009-07-13 23:47:02 PDT
This seemingly is a problem on Linux as well.

Ubuntu bug:
https://bugs.launchpad.net/bugs/385816

I have this on Shiretoko 3.5 final.
Comment 22 User image Luke Iliffe (Harlequin99) 2009-10-10 01:23:15 PDT
On windows 7 RC with the latest trunk when I maximize the window the grippy is present for a split second then disappears. This results in the expected behaviour of not being able to resize the maximized windows using the grippy.

(Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091009 Minefield/3.7a1pre ID:20091009051317)
Comment 23 User image Jacob Bundgaard 2009-11-21 10:20:33 PST
I'm using:
Mozilla/5.0 (Windows; U; Windows NT 6.0; da; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB5 (.NET CLR 3.5.30729)
And also see this behavior, but actually it doesn't annoy me. For me, it's a feature, not a bug.
The only reason i see for changing it, is to imitate the behavior of other Windows Applications.

Would it be worth considering to keep the "bug", and actually implement it as a feature, as there's probably someone like me, who likes to resize their windows without having to click the Restore button first?
Comment 24 User image Nickolay_Ponomarev 2009-11-21 11:00:00 PST
> Would it be worth considering to keep the "bug"

Possibly, but the way it worked in Firefox 3.5 was broken (code-wise) and it's fixed already in the development version. So your suggestion is effectively a request for another change.

If you care about it a lot, you could submit it separately, try to get input from the UI people, make a patch, get it reviewed and landed. Or just implement it as an extension, which should be simpler.
Comment 25 User image Jacob Bundgaard 2009-11-21 12:29:39 PST
Okay. If a fix's already implemented, i'll not go any further with it.
After all, this is unintentional, and might confuse some people.
Comment 26 User image M van Ketel 2009-12-10 03:58:19 PST
My 2 cents: Just like Jacob I prefer this 'feature' actually I'd like to see it in the window directly if started maximized. Why would one to prefer to use 1 click and a click-drag to resize the window to its preferred size ins tead of the click-drag at once? This used to be the way in SeaMonkey 1.1.x and now it is is gone in SM 2.0 (probably following Fx) :(
Comment 27 User image Nickolay_Ponomarev 2010-01-09 11:09:36 PST
So this is fixed by bug 472258, as I said before. Marking as such.
Comment 28 User image Tracy Walker [:tracy] 2010-04-06 09:46:31 PDT
*** Bug 535107 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.