The default bug view has changed. See this FAQ.

When reloading a page, Firefox shouldn't redisplay it until the current scroll position has been reached

NEW
Unassigned

Status

()

Firefox
General
9 years ago
4 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

3.6 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

With some pages (e.g. see the above URL), when Firefox reloads the page (either due to an automatic reload or because the user clicked on the Reload button) it displays the beginning of the page then restores the scroll position. The problem is that it distracts the user from reading the page and this is particularly annoying on pages that need to refresh their contents regularly.

Reproducible: Always

Steps to Reproduce:
(Happens every time with some pages, never happens with other pages.)
1. Open the above URL.
2. Scroll downwards.
3. Click on the Reload button.
Actual Results:  
First the beginning of the page is redisplayed, then the scroll position is restored.

Expected Results:  
Firefox shouldn't redisplay the page until it can render it at the wanted position. In particular, this means that if the page hasn't changed, nothing should be redisplayed.
(Reporter)

Updated

9 years ago
Summary: When reloading a page, Firefox redisplay it until the current scroll position has been reached → When reloading a page, Firefox shouldn't redisplay it until the current scroll position has been reached
Maybe you can do something with the pref nglayout.initialpaint.delay ?
100, 1000 or 10000? :)
http://kb.mozillazine.org/About:config
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Maybe you can do something with the pref nglayout.initialpaint.delay ?
> 100, 1000 or 10000? :)

This would be even worse (the value would have to be at least 5000, but I know this would be too much for general browsing, as I'm already much annoyed by bug 18333), perhaps unless there's such an option for reloads *only*.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

6 years ago
I'm reopening the bug as I could reproduce it with Firefox 3.6.14 with a new profile.

1. Open the URL:
http://www.sports.fr/football/directs/2011/ligue-1/98201/comment/lille-lyon.html
2. Scroll downwards.
3. Wait for 1 minute (the page automatically reloads every minute) or click on the Reload button.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-GB; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Vincent, did Firefox 4 change this in anyway?
Whiteboard: [CLOSEME 2010-11-01]
Version: unspecified → 3.6 Branch
(Reporter)

Comment 7

6 years ago
I can't test Firefox 4 as it isn't available on my Mac OS X and Linux machines, but I could try the nightly, and the bug still occurs.

Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110515 Firefox/6.0a1
Duplicate of this bug: 774200
This still happens. It affects Fennec as well where it happens more frequently (presumably because pages load more slowly).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

5 years ago
OS: Mac OS X → All
Hardware: PowerPC → All
You need to log in before you can comment on or make changes to this bug.