Closed Bug 419549 Opened 12 years ago Closed 12 years ago

click bookmark item does not work

Categories

(Firefox :: Bookmarks & History, defect, P1, major)

x86
All
defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta4

People

(Reporter: bugmozz, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file)

OK : 20080225_1336_firefox-3.0b4pre.en-US.win32.zip
NG : 20080225_1416_firefox-3.0b4pre.en-US.win32.zip

bug 403263 seem to cause this.
Middle-clicking a bookmark throws:
  ASSERT: null node
  Stack Trace:
  0:PU_nodeIsFolder(null)
  1:BT_onClick([object MouseEvent])
  2:onclick([object MouseEvent])
Flags: blocking-firefox3?
Blocks: 403263
No longer depends on: 403263
Duplicate of this bug: 419550
Checkins to module PhoenixTinderbox between 2008-02-25 13:36 and 2008-02-25 14:15 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1203975360&maxdate=1203977759
Severity: normal → major
OS: Windows XP → All
Target Milestone: --- → Firefox 3 beta4
Attached patch patchSplinter Review
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #305703 - Flags: review?(mak77)
Comment on attachment 305703 [details] [diff] [review]
patch

working correctly, code appear correct
Attachment #305703 - Flags: review?(mak77) → review+
To avoid nightlies hitting this bug on the b4-freeze-day, I'm going to land this with post facto approval / blocking status.
mozilla/browser/base/content/browser-places.js 1.96
mozilla/browser/components/places/content/bookmarksPanel.xul 1.11
mozilla/browser/components/places/content/controller.js 1.207
mozilla/browser/components/places/content/history-panel.xul 1.15
mozilla/browser/components/places/content/places.js 1.131
mozilla/browser/components/places/content/sidebarUtils.js 1.4
mozilla/browser/components/places/content/utils.js 1.104
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Flags: blocking-firefox3? → blocking-firefox3+
Attachment #305703 - Flags: approval1.9?
verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre and the same nightly on Win XP
Status: RESOLVED → VERIFIED
Duplicate of this bug: 419827
Looks like this caused bug 421210.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.