Closed Bug 419647 Opened 14 years ago Closed 14 years ago

Add a sexy theme browser

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: philipp.weissenbacher, Assigned: lorchard)

References

()

Details

Attachments

(2 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 

Currently there is only a list view. Add a thumbnail view to give a better overview (e.g. ability to quickly compare different themes).

See http://www.flickr.com/search/?q=Kilmainham+Gaol&z=t for a good example.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
We plan on taking care of this with a theme browser or manager at some point.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 3.x (triaged)
Target Milestone: 3.x (triaged) → 3.4
Changing name and sexy++ to it gets loving.
Summary: Add a thumbnail view → Add a sexy theme browser
Severity: enhancement → major
Assignee: nobody → rdoherty
OS: Windows XP → All
Hardware: PC → All
Target Milestone: 3.4 → 3.4.3
Ad initial design thoughts: Frankly, I actually thought of something more simple, like just thumbnails, thus depicting themes by their appearance rather than by their name (which is the currently proposed way).
So that it be easy to select a theme by it's appearance rather than by it's name, category or popularity.

Maybe someone could incorporate this light table kind of design somehow.
-> Les
Assignee: rdoherty → lorchard
Some newer thoughts on theme browsers.

The first is a basic layout with lots of thumbnails on the screen, each of which would just link to the theme's details page.

The second is a list of thumbnails, where clicking on one gives a larger preview.  In this case, because of the design work going on with the category list right now, I've moved the selection of Theme category to the main category list (it wouldn't be part of the theme browser).

- benefits:  not having to go to another page to see a larger preview
- downsides: fewer thumbnails on the screen at a time for quick visual scan

Thoughts?  Completely new directions?  Something simpler you've seen elsewhere?
At first: Great work!
I very much like the first one, because it really gives you a quick overview of everything. Though, I'd appreciate a meta category "All" which lists all themes.
For me either, paginated or scroll, would work just fine. I wouldn't show ratings or names or make it sortable. Maybe we could cheat a bit by sorting the thumbnails by their popularity ...

The second is good too, although I'd prefer less many borders (to make it look smoother).
Here's an implementation of a thumbnail grid style theme browser.
Attachment #323139 - Flags: review?(laura)
Comment on attachment 323139 [details] [diff] [review]
Initial stab at a thumbnail grid style browser

I see the names of the themes coming up as "Notice: undefined".  View source tells me <b>Notice</b>:  Undefined variable: icon in <b>/opt/amo/site/app/views/addons/browse_thumbs.thtml</b> on line <b>82</b><br />
Attachment #323139 - Flags: review?(laura) → review-
Looks like I had my settings not sufficiently noisy to produce errors and warnings in Cake.  Changed that, saw the problem, and this new patch should do it.
Attachment #323139 - Attachment is obsolete: true
Attachment #323476 - Flags: review?(laura)
Comment on attachment 323476 [details] [diff] [review]
Second attempt at the thumbnail browser

You've accidentally included changes to config/core.php which should probably be in config/config-local.php (which svn ignores).  
In addition, the theme browser for me replaces the page and opens with no CSS - I think it's an interaction with an error in the advanced search javascript.  I'll wait until that's been backed out by fligtar before trying again.
Attachment #323476 - Flags: review?(laura) → review-
Posting this patch, sans config changes.  Might have dependencies on bug 436973, but I don't think the code on my end will change.
Attachment #323476 - Attachment is obsolete: true
Attachment #323492 - Flags: review?(laura)
Comment on attachment 323492 [details] [diff] [review]
Third attempt, this time without my local config changes

Yay, third time lucky.
Attachment #323492 - Flags: review?(laura) → review+
Looks like this is checked in with r14511 and working on preview:

https://preview.addons.mozilla.org/en-US/firefox/browse/type:2/cat:all?sort=name
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Yeah! That's exactly what I've meant! Great work! Thanks!
I filed a spinoff, bug 437124, but otherwise, this looks great.

When you sort by date, there are last-updated dates of "Updated November 30, 1999", but that's not specific to this feature; you can see it on production: https://addons.mozilla.org/en-US/firefox/browse/type:2/cat:all?show=20&sort=updated&page=14

Verified FIXED.  Nice work, Les!
Status: RESOLVED → VERIFIED
Looks really good -- great work!

(In reply to comment #14)
> Looks like this is checked in with r14511 and working on preview:
> 
> https://preview.addons.mozilla.org/en-US/firefox/browse/type:2/cat:all?sort=name
> 

Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.