Closed Bug 419665 Opened 12 years ago Closed 12 years ago

VC9 on Vista builds a manifest file with duplicate entries

Categories

(Firefox Build System :: General, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1a1

People

(Reporter: crowderbt, Assigned: lsblakk)

References

Details

(Keywords: fixed1.9.0.2)

Attachments

(2 files, 1 obsolete file)

Adding the following to my .mozconfig file (on Ted's advice) solves the problem for me.

LDFLAGS="-MANIFESTUAC:NO"
Summary: VC9 builds on Vista build a manifest file with duplicate entries → VC9 on Vista builds a manifest file with duplicate entries
Duplicate of this bug: 416739
configure sets -MANIFEST:NO now so adding LDFLAGS="-MANIFESTUAC:NO" separately is no longer necessary.
Not true. It only sets -MANIFEST:NO if you're building jemalloc, which doesn't currently build with VC9 anyway.
Tested on a Vista build with Visual Studio Express 2k8 to great success.
Attachment #320287 - Flags: review?(ted.mielczarek)
Comment on attachment 320287 [details] [diff] [review]
Sets LDFLAGS="-MANIFESTUAC:NO" in configure.in

You need to follow the example on the line above, and do LDFLAGS="$LDFLAGS ..." The variable can be pre-populated from the environment. Otherwise, looks good!
Attachment #320287 - Flags: review?(ted.mielczarek) → review+
Assignee: nobody → lukasblakk
Actually, when I first wrote/tested it with LDFLAGS="$LDFLAGS -MANIFESTUAC:NO" it did not work, only with just LDFLAGS="-MANIFESTUAC:NO" did it work.  Not sure what that means, but that's what my builds showed.
Hm, what does $LDFLAGS have in it at that point? You can't just drop the previous value on the ground, that's no good. (You can just stick an echo "LDFLAGS: $LDFLAGS" in there, and look in objdir/config.log)
Status: NEW → ASSIGNED
Now it doesn't work with either LDFLAGS="-MANIFESTUAC:NO"  or with echoing the LDFLAGS - either results in "bad file number".
Okay - this works, the trouble I was having earlier was because of not knowing to run autoconf to generate configure.  Now it's all fine.  There is nothing in $LDFLAGS prior to this being set for the record.
Attachment #320287 - Attachment is obsolete: true
Attachment #321840 - Flags: approval1.9?
Right, typically LDFLAGS will be empty, but you're allowed to pass some LDFLAGS in your mozconfig or on the commandline, so you have to preserve those.

FWIW, we should get this checked into mozilla-central (once it opens), and then worry about 1.9.
Comment on attachment 321840 [details] [diff] [review]
Sets LDFLAGS="$LDFLAGS -MANIFESTUAC:NO" in configure.in

Policy is going to be to bake patches on mozilla-central first, so we'll need to wait for that to open for checkins.
Attachment #321840 - Flags: approval1.9?
Flags: wanted1.9.0.x?
This one is for mozilla-central.
Attachment #323485 - Flags: review?(ted.mielczarek)
Comment on attachment 323485 [details] [diff] [review]
Adding -MANIFESTUAC:NO to configure.in for Vista builds

You don't need to request separate review for mozilla-central. You might need to coordinate landing with the sheriff for the time being, though.
Attachment #323485 - Flags: review?(ted.mielczarek) → review+
Pushed as changeset 15225:00256c63e6ed.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0
Comment on attachment 323485 [details] [diff] [review]
Adding -MANIFESTUAC:NO to configure.in for Vista builds

I think we should get this on the 1.9.0 branch too, once that's possible.
Comment on attachment 323485 [details] [diff] [review]
Adding -MANIFESTUAC:NO to configure.in for Vista builds

Simple patch that will make building with VC9 on Vista possible out of the box.
Attachment #323485 - Flags: approval1.9.0.2?
Flags: wanted1.9.0.x? → wanted1.9.0.x+
Target Milestone: mozilla2.0 → mozilla1.9.1a1
Comment on attachment 323485 [details] [diff] [review]
Adding -MANIFESTUAC:NO to configure.in for Vista builds

Approved for 1.9.0.2. Please land in CVS. a=ss
Attachment #323485 - Flags: approval1.9.0.2? → approval1.9.0.2+
Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1995; previous revision: 1.1994
done
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.