Last Comment Bug 419669 - SVN Account Request - Romi Hardiyanto <romihardiyanto@gmail.com>
: SVN Account Request - Romi Hardiyanto <romihardiyanto@gmail.com>
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Mark Smith [:xb95]
:
:
Mentors:
Depends on:
Blocks: 433577
  Show dependency treegraph
 
Reported: 2008-02-26 10:42 PST by Romi Hardiyanto
Modified: 2010-05-09 14:51 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
My ssh public key for svn+ssh (599 bytes, text/plain)
2008-02-26 10:44 PST, Romi Hardiyanto
no flags Details

Description Romi Hardiyanto 2008-02-26 10:42:09 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; id; rv:1.9b4pre) Gecko/2008022313 Minefield/3.0b4pre
Build Identifier: 

Hi, I'd like to get SVN commit access.  I'm the en-US owner.  I have a CVS account from bug 413283.
I don't have LDAP account
I need write access to the following locations:

http://svn.mozilla.org/addons/trunk/site/app/locale/id/

Thanks.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Romi Hardiyanto 2008-02-26 10:43:06 PST
(In reply to comment #0)

Ooops, sorry should be

Hi, I'd like to get SVN commit access.  I'm the id owner.  I have a CVS account from bug 413283.
I don't have LDAP account
I need write access to the following locations:

http://svn.mozilla.org/addons/trunk/site/app/locale/id/

Thanks.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 

Comment 2 Romi Hardiyanto 2008-02-26 10:44:55 PST
Created attachment 305805 [details]
My ssh public key for svn+ssh
Comment 3 Wil Clouser [:clouserw] 2008-02-26 13:14:39 PST
a=clouserw for svn.mozilla.org/addons/trunk/site/app/locale/id/
Comment 4 Mark Smith [:xb95] 2008-02-26 16:59:44 PST
This has been done.  It make take 5-10 minutes for the changes to fully propagate out to the servers.  Please let me know if you have any problems.
Comment 5 Romi Hardiyanto 2008-03-06 00:34:37 PST
Reopening,

Mark, I cannot commit my files to svn.mozilla.org/addons/trunk/site/app/locale/id/:
...
Sending        messages.mo
Sending        messages.po
Transmitting file data ..svn: Commit failed (details follow):
svn: Access denied
svn: Your commit message was left in a temporary file:
...

But I can connect using ssh successfully (and produce some svn protocol messages i think)

Couldn't be file permissions problem? This is my first try for svn commit.
Comment 6 Wil Clouser [:clouserw] 2008-03-07 20:49:18 PST
Talked with Romi online and didn't see anything obvious wrong.  Can you double check this is correct?
Comment 7 Romi Hardiyanto 2008-03-07 23:11:17 PST
FYI, I just comitted string update for 'id' locale and I have no errors.
Comment 8 Mark Smith [:xb95] 2008-03-10 10:25:20 PDT
I'm a little confused - you just committed a string update for 'id' locale, i.e., it works now?  Or is it still broken?
Comment 9 Romi Hardiyanto 2008-03-12 09:58:05 PDT
Sorry, it should said:
... comitted string update for CVS for 'id' locale and I have no errors.

Still got stranded in cuxhaven, waiting for bad weather gone. Last time I check (Sunday Morning PST), I still can't commit to SVN, with the same error message as per comment 5.
Comment 10 Mark Smith [:xb95] 2008-03-12 15:58:23 PDT
So it seems that we didn't have it setup so localizers could access the id locale.  Everything else seems to be in place.

Please try it again.  If this doesn't work, I'll have to pull in the big guns and get Aravind to school me on what I broke...

Let me know either way, please!
Comment 11 Mark Smith [:xb95] 2008-03-13 13:26:00 PDT
Well, I believe this is resolved.  If there are still issues, please reopen, and then I will get Aravind in to take a look.

Again, sorry for the troubles with getting you access.
Comment 12 Romi Hardiyanto 2008-03-21 06:55:36 PDT
Happy easter, though no luck for me with this bug...

Just trying to commit but still has the same error message in comment 5.
Then trying to install tortoise+putty in windows machine, the same error is there...

Waiting for the big gun then :-)
Comment 13 Mark Smith [:xb95] 2008-03-21 11:34:18 PDT
CCing Aravind.  Would you mind taking a look at this?  I'm not sure what is not properly connected here.

Romi, I see you are authenticating correctly against the machine per the logs, I double checked all of the configuration... it really does look correct.  Hopefully Aravind can shed some light on this...
Comment 14 Romi Hardiyanto 2008-03-22 04:51:44 PDT
Maybe this is what called Easter Luck.

Just some minute ago, without changing anything in my computer (no luck compiling subversion with debug option), fire up terminal, and did svn commit, yes it worked!

So let's put the big down then, thank you everyone, closing this bug then :D
Comment 15 Mark Smith [:xb95] 2008-03-23 01:29:26 PDT
Hurrah!  Maybe my poking around collapsed the wave function and allowed the commit to go through.  Glad it's working now, and again, sorry for the trouble!

Note You need to log in before you can comment on or make changes to this bug.