Wrong handling of folders that contain subfolders with an UW-IMAP-server

RESOLVED DUPLICATE of bug 301714

Status

--
major
RESOLVED DUPLICATE of bug 301714
11 years ago
6 years ago

People

(Reporter: kontakt, Assigned: Bienvenu)

Tracking

1.8 Branch
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Thunderbird/Version 2.0.0.9 (20071031)

Some of the problems I will report are already in Bugzilla, but I think they have all the same reason, so here is a summary of what happens:

All the described problems ONLY affect folders that contain subfolders. Folders, that contain messages, can be created, renamed and deleted without any problem. 

CREATING folders for subfolders: Folder isn't shown immediately, you have to restart Thunderbird OR simply close and reopen the folder tree.

RENAMING folders for subfolders: Error message "No such folder", until you uncheck "Show only subscribed folders" in Thunderbird's advanced IMAP Server-Settings. After unchecking this, also Folders for subfolders can be renamend at the first view, but after refreshing or restart the old name ist shown again. This happens NOT, when the folder already contains subfolders. Then the renaming seems also work correct at the first view, but after refresh or restart, there is a new folder with the new name, besides the old folder's name.

DELETING folders for subfolders: At the first view they are deleted, but after refresh or restart, they reappear. If the folder contained subfolders, that contained only messages, they are deleted, but the parent folder still exists. So the conclusion to me is: folders containing subfolders can't be deleted in Thunderbird with an UW-IMAP-Server. 

Reproducible: Always

Steps to Reproduce:
1.Create folder that should contain subfolders
2.Try to rename folder with subfolders
3.Try to delete folder with subfolders
4.Refresh folder tree or restart T-Bird
Actual Results:  
1. Created folfers are not shown immediatly, need refresh or restart
2. New folder with new name is shown beside the old folder (after refresh or restart)
3. Folder is not deleted after refresh or restart

Expected Results:  
It should be possible to create, rename or delete folders, that contain subfolders in the same way as folders containig only messages.

ANY other tested mail client has no problem with this. Testet it with Pegasus, Outlook Express, Outlook, Eudora 7.1 and WinPMail. Tested it with about 30 different Computers, most of them running Windows XP, some Windows 2000, 2 Server 2003.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0
> Some of the problems I will report are already in Bugzilla
Bug 399769 & Bug 409839 ?

> "with an UW-IMAP-server" in bug summary & comment #0
UW-IMAP unique problem?

> RENAMING folders for subfolders: Error message "No such folder",
> until you uncheck "Show only subscribed folders"

Can you get IMAP protocol log of both "Show only subscribed folders"=OFF & "Show only subscribed folders"=ON?
See Bug 402793 Comment #1 for getting protocol log. 
(Reporter)

Comment 2

11 years ago
Created attachment 306195 [details]
Log with "Show only subscribed folders" ON

Log shows: 

- Creating Folder
At this point error message: "No such folder"
- Refresh folder tree in order to see the new folder (not shown immediately after creation)
- Renaming the folder
- Refreshing tree again
(Reporter)

Comment 3

11 years ago
Created attachment 306196 [details]
Log with "Show only subscribed folders" OFF

Log shows: 

- Creating Folder
- Refresh folder tree in order to see the new folder (not shown immediately after creation)
- Renaming the folder
- Refreshing tree again
(Reporter)

Comment 4

11 years ago
Yes, Bug 399769 & Bug 409839, seems to be the same problem I reported in Point 1.

It seems to be a unique UW-IMAP-Problem, although I can't say it with 100% doubtlessness. I recognized the problem together with mercury 4.52, but when searching for a solution, I found out in several forums in the net, that many users have the same problems with T-Bird and other UW-IMAP-Servers. 

Attached the two logs you requested.
Attachment #306195 - Attachment filename: tbirdlog_only_subbscr_folders_on → tbirdlog_only_subbscr_folders_on.txt
Attachment #306195 - Attachment mime type: application/octet-stream → text/plain
Attachment #306196 - Attachment filename: tbirdlog_only_subbscr_folders_off → tbirdlog_only_subbscr_folders_off.txt
Attachment #306196 - Attachment mime type: application/octet-stream → text/plain
(In reply to comment #2)
> Log with "Show only subscribed folders" ON

Appended "/" (==server's hierarchy separator character) to "milbox name" when rename by Tb looks to be cause of problem.
> http://www.faqs.org/rfcs/rfc3501.html
Sorry but I don't know whose fault, Tb's fault or IMAP server's fault.

>(subscribe & list just after 9 create "Testfolder/")
>(Note: trailing "/" has meaning at least when create)
> S-INBOX:SendData: 10 subscribe "Testfolder/"
> S-INBOX:CreateNewLineFromSocket: 10 OK SUBSCRIBE completed.
> S-INBOX:SendData: 11 list "" "Testfolder/"
> S-INBOX:CreateNewLineFromSocket: 11 OK LIST completed.

>(list while rename operation)
> S-INBOX:SendData: 16 list "" "Testfolder"
> S-INBOX:CreateNewLineFromSocket: * LIST (\Noselect) "/" Testfolder
> S-INBOX:CreateNewLineFromSocket: 16 OK LIST completed.
(subscribe & unsubscribe while rename operation) 
> S-INBOX:SendData: 18 subscribe "Testfolder_new"
> S-INBOX:CreateNewLineFromSocket: 18 OK SUBSCRIBE completed.
> S-INBOX:SendData: 19 unsubscribe "Testfolder"
> S-INBOX:CreateNewLineFromSocket: 19 NO That object is not subscribed.
(rename while rename operation) 
> S-INBOX:SendData: 20 rename "Testfolder/" "Testfolder_new/"
> S-INBOX:CreateNewLineFromSocket: 20 NO No such folder.

Another funny flow is seen. Why Tb tries to create "Trash"?
(Trash is not subscribed, then Trash is unknown, then try to create?)  

> S-INBOX:SendData: 14 list "" "Trash"
> S-INBOX:CreateNewLineFromSocket: * LIST (\NoInferiors) "/" Trash
> S-INBOX:CreateNewLineFromSocket: 14 OK LIST completed.
> S-INBOX:SendData: 15 create "Trash"
> S-INBOX:CreateNewLineFromSocket: 15 NO Path or folder creation error (check folder name).
Changing to Networking:IMAP
Assignee: nobody → bienvenu
Component: General → Networking: IMAP
Product: Thunderbird → Core
QA Contact: general → networking.imap
Version: 2.0 → 1.8 Branch
To David Bienvenu:

(Q1) Trailing "/" of "mailbox name" in next subscribe & list just after '9 create "Testfolder/" is proper? 
> 10 subscribe "Testfolder/"
> 11 list "" "Testfolder/"
(It seems that Tb thinks "mailbox name==Testfolder/" instead of "Testfolder", )
(after creation of Testfolder by '9 create "Testfolder/"'.                    )

(Q2) Trailing "/" of "mailbox name" in rename is proper/permitted?
> 20 rename "Testfolder/" "Testfolder_new/"
Setting dependency of Bug 399769 & Bug 409839
Blocks: 399769, 409839
(Reporter)

Comment 9

11 years ago
I am not quite sure, if I understood this correctly (English is not my native language): Should I try to set an "/" after the folder's name? I tried it an few minutes ago. It brings no change to the situation. 
(In reply to comment #9)
> Should I try to set an "/" after the folder's name?

No need to do so.
Please see "CREATE Commmand" section of RFC 3501 and read description about "mailbox name" which is suffixed with the server's hierarchy separator character.
> http://www.faqs.org/rfcs/rfc3501.html
> 6.3.3.  CREATE Command
No longer blocks: 399769, 409839
Depends on: 399769, 409839
Created attachment 306807 [details]
IMAP log when Gmail IMAP

When Gmail IMAP, NAMESPACE is supported, and appended "/" was not observed in create, susbscribe, rename etc., although both phenomena of Bug 409839(create) & Bug 399769 was observed with Gmail IMAP too.

Phenomenon of appended "/" seems to occur only when no NAMESPACE support. And your problem of "rename failure" looks to be different issue from Bug 409839 or Bug 399769, although phenomena of both bugs is also involved in your problem.
Can you test with "NAMESPACE enabled"?
(Reporter)

Comment 12

11 years ago
Ok, tested it now with Namespace enabled. Makes it even worse. A second trash folder is created with the Name "trash.INBOX" and the creation of folders containing subfolders is not possible anymore.
Product: Core → MailNews Core
> 10 subscribe "Testfolder/"

This was Tb's known Bug 301714. Setting dependency to that bug.
Depends on: 301714

Comment 14

6 years ago
 Michael, is problem gone?


(In reply to WADA from comment #13)
> > 10 subscribe "Testfolder/"
> 
> This was Tb's known Bug 301714. Setting dependency to that bug.
Whiteboard: [closeme 2012-07-15]

Comment 15

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-07-15]
Bug 301714 is already fixed. So closing as dup of bug 301714. For problem other than "Tb doesn't remove trailing / in LIST response from delete command", open separate bug, please.
No longer depends on: 301714
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 301714
You need to log in before you can comment on or make changes to this bug.