unit test boxes should pull by date (use MOZ_CO_DATE)

RESOLVED WONTFIX

Status

Release Engineering
General
P3
normal
RESOLVED WONTFIX
11 years ago
5 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Tinderboxes generally use MOZ_CO_DATE to get the source that corresponds to the exact time they report as their start time rather than picking up files that are checked in while they're pulling.  The unit test boxes don't seem to do this; looking at this log:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1204089656.1204091056.24141.gz&fulltext=1

I don't see any -D <date> in the cvs commands used to check out the source.  Compare to this:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1204087920.1204089821.21314.gz&fulltext=1

which does pass MOZ_CO_DATE to client.mk.  They should do this so the source they have more reliably corresponds to the build start times they report to tinderbox.
Status: NEW → ASSIGNED
Assignee: nobody → rcampbell
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Component: Testing → Release Engineering: Projects
OS: Linux → All
Product: Core → mozilla.org
Hardware: PC → All
Version: Trunk → other
Assignee: rcampbell → nobody
Status: ASSIGNED → NEW
QA Contact: testing → release
Priority: -- → P3
Blocks: 393112
We also need this for unittests. 

The unittest machines rebuild with extra options, and we need to make sure we're testing the exact same bits as the tinderbox builds.

Updated

10 years ago
Duplicate of this bug: 388355
I think this a WONTFIX for Firefox 3.0 at this point. For mozilla-central/1.9.1 it doesn't matter much because we lack a blame column. More importantly, these machines report the exact revision they have built. I'm going to close this bug under these assumptions. Please re-open if I'm way off here, though.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 4

8 years ago
Moving closed Future bugs into Release Engineering in preparation for removing the Future component.
Component: Release Engineering: Future → Release Engineering
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.