firefox default font settings are too small

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: Matěj Cepl, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12
Build Identifier: Fedora Rawhide different builds of Firefox 3 beta 2 and beta3

(originally filed as Fedora/Rawhide bug on the above shown URL)

Firefox shows many web sites with tiny fonts that really unreadable.
A user said that his firefox default font settings in windows are the same with
fedora but sites diplayed differently.
So the user has to go to advanced font settings and set "minimum font size" to a
different value(on every language he use). I think current value is "none"
I think that this situation is not ideal for novice fedora users.
I have to mention that this also is the case for epiphany.

Reproducible: Always

Steps to Reproduce:
1.start firefox
2.
3.
Actual Results:  
fonts are too small and "minimum font size" is not set.

Expected Results:  
Either fonts should be always sanely sized (probably not possible given the wide variety of webs out there) or "minimum font size" should be default to some sane size.

Comment 1

10 years ago
Matej, can you provide some examples of sites and what their font sizes are?

I agree that some sites look too small, but it's usually because they do specify such ridiculously small fonts, sometimes using small point sizes (6pt, 7pt, etc.), sometimes using small percentages (65%, 70%, etc.), and sometimes using absolute pixel values (7px, 8px).

I think you need to install Firefox, inspect an element where the font is too small and understand which of the above is the real problem.  Then the developers can know which problem we are trying to fix and what the best solution is.

But yes, I have set my minimum font size to 10pt, and I find that's much better than the default of None. ;-)
(Reporter)

Comment 2

10 years ago
Mikel, I hope that the original reporter replies to your request.
Blocks: 469306

Comment 3

9 years ago
I can confirm this.

"minimum font size" should be default to some sane size is not the solution, as a sane size depends on your resolution (consider all kind of displays, from iphone to large screens).
The problem is in the Linux fonts setup and should be handled by distributions, as the Windows version looks good out of the box.

Closing this as Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.