Last Comment Bug 420023 - [ta-LK] Thunderbird - Sri Lankan Tamil Localization
: [ta-LK] Thunderbird - Sri Lankan Tamil Localization
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: x86 All
: -- enhancement (vote)
: ---
Assigned To: Localization Registration Bugs
:
:
Mentors:
Depends on:
Blocks: tb3-l10n-ta-LK 477770
  Show dependency treegraph
 
Reported: 2008-02-27 21:28 PST by Sarves
Modified: 2011-04-11 22:25 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Thunderbird 2.0 in Srilankan Tamil (136.45 KB, application/gzip)
2008-03-04 04:19 PST, Kavitha.Loganathan
no flags Details
ta-LK language pack for Mozilla Thunderbird 2 (136.45 KB, application/x-gzip)
2008-05-23 05:06 PDT, Sarves
no flags Details
ta-LK l10n sorce files for TB3 (218.05 KB, application/x-gzip)
2008-10-03 04:53 PDT, Rohana Dasanayaka
no flags Details
ta-LK l10n source files for TB3 (234.96 KB, application/x-gzip)
2009-01-21 03:13 PST, Rohana Dasanayaka
bugzilla: review+
Details
ta-LK l10n sorce files for TB3 (234.99 KB, application/x-gzip)
2009-01-23 01:57 PST, Rohana Dasanayaka
bugzilla: review-
Details
ta-LK l10n sorce files for TB3 (234.64 KB, application/x-gzip)
2009-01-25 03:15 PST, Rohana Dasanayaka
no flags Details
ta-LK l10n sorce files for TB3-Beta2 (288.39 KB, application/x-gzip)
2009-02-13 03:21 PST, Rohana Dasanayaka
no flags Details
Missing files for ta-LK of Thunderbird3 (5.07 KB, application/x-gzip)
2009-02-14 23:41 PST, Rohana Dasanayaka
no flags Details
file to be placed to fix installer problem (5.02 KB, application/octet-stream)
2009-02-17 20:57 PST, Rohana Dasanayaka
no flags Details

Description Sarves 2008-02-27 21:28:29 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla Thunderbird 2.0

Product : Mozilla Thunderbird 2.0
Language : ta-LK (Sri Lankan Tamil)
Contact name : Kavitha Loganathan (Kavitha)
E-Mail : kavitha2325@yahoo.com
Web page : www.lakapps.lk

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Sarves 2008-03-03 04:08:20 PST
I tried to upload the xpi. Because the size is more than 300k, bugzilla not allow me to upload. 
Kavitha, could you look into that?.

~Sarves
Comment 2 Kavitha.Loganathan 2008-03-04 04:19:07 PST
Created attachment 307218 [details]
Thunderbird 2.0 in Srilankan Tamil
Comment 3 Sarves 2008-03-04 05:27:16 PST
Why u have uploaded tar.gz file Kavitha. Shouldnt it be an xpi?
Comment 4 Sarves 2008-03-07 21:14:19 PST
Kavitha, shall we upload the xpi also to this bug?
Comment 5 Kavitha.Loganathan 2008-03-16 21:18:07 PDT
(In reply to comment #4)
> Kavitha, shall we upload the xpi also to this bug?
> 

I want to do some modifications in the xpi file. I will upload the xpi as soon as possible.... 
Comment 6 Sarves 2008-04-02 08:26:00 PDT
This Thunderbird pack is installed in many places our country  and its successfully working. What are the steps we should take to get this on Mozilla server / get CVS access?
Comment 7 Sarves 2008-05-23 05:04:41 PDT
Kavitha, I have filed a bug to get CVS, find it  :
https://bugzilla.mozilla.org/show_bug.cgi?id=435392
Comment 8 Sarves 2008-05-23 05:06:30 PDT
Created attachment 322243 [details]
ta-LK language pack for Mozilla Thunderbird 2 

ta-LK pack for Mozilla Thunderbird 2
Comment 9 Sarves 2008-06-03 05:05:23 PDT
We are getting ready for Thunderbird 3.
Comment 10 Axel Hecht [:Pike] 2008-07-01 05:17:59 PDT
Comment on attachment 322243 [details]
ta-LK language pack for Mozilla Thunderbird 2 

The reviews should go on the source files instead of the language pack, cancelling this review.

I ran compare-locales on the source attachment, but that seems to contain only the tb-specific parts, not toolkit, so I can't really r+ that either.

There is something funky in mail/installer/installer.inc, though. Not sure what, just for reference.

I assume that you're pushing Firefox 3 forward first?
Comment 11 Sarves 2008-07-01 10:26:59 PDT
Thanks Alex. We will come up with correct and good pack soon.

Yes Alex, we are planning to push FF3 first and also we would not miss the TB 3.0 too.
Comment 12 Rohana Dasanayaka 2008-10-03 04:53:24 PDT
Created attachment 341609 [details]
ta-LK l10n sorce files for TB3

Sarves,

As I discussed with you, I prepared the l10n source files for TB3. The "comapre-locale" suggests me that 40% completed.

shall we do string-translation further to reach 80%-90% and check it again after that. Then you may request l10n review from Axel. Thanks.
Comment 13 Sarves 2008-10-03 15:16:06 PDT
Thanks Rohana.
Sure, we will do that. I will let u know and upload it here once its done.
Comment 14 Simon Paquet [:sipaq] 2009-01-13 05:15:35 PST
Rohana, Sarves,
how far along are you at the moment with the Thunderbird ta-LK localization? Can you please give me an update?
Comment 15 Sarves 2009-01-14 21:12:37 PST
Rohana,

I mailed the Thunderbird pack to you. Could you compile and find the % of completion quickly? Then we can give an update to Simon.
Comment 16 Rohana Dasanayaka 2009-01-16 01:21:46 PST
Sarves, Simon,

Now, 66% completed, but there are  many Missing/Obsolete strings (3 months old pack-comment #12) and a few errors. I can help to resolve those. 

Sarves, you may continue with translation

Hope, can reach the target to land on TB3.
Comment 17 Sarves 2009-01-16 01:34:42 PST
Thx Rohana. Could you upload the newly complied pack so that we can work on it. Yes we will try our best to finish this.

Sarves
Comment 18 Rohana Dasanayaka 2009-01-16 02:00:52 PST
(In reply to comment #17)
> Thx Rohana. Could you upload the newly complied pack so that we can work on it.
> Yes we will try our best to finish this.
> 
> Sarves

I will upload it as soon as possible, but you may continue with present set of files.
Comment 19 Rohana Dasanayaka 2009-01-21 03:13:29 PST
Created attachment 357933 [details]
ta-LK l10n source files for TB3

Attached herewith is "ta-LK" L10n files for Thunderbird 3. Locally-run compare-locale gives no error and indicates 79% completion. We kindly request l10n review for this and hope to upload modified files ( >80% completion) soon after "string-freeze". Thanks.
Comment 20 Simon Paquet [:sipaq] 2009-01-21 04:22:34 PST
Comment on attachment 357933 [details]
ta-LK l10n source files for TB3

I'll do the l10n review for Thunderbird source files.
Comment 21 Sarves 2009-01-21 05:12:05 PST
Thanks Rohana for compiling and uploading the pack. 
Simon, thanks for ur response too :) Hope that we can opt-in very soon!

Sarves
Comment 22 Axel Hecht [:Pike] 2009-01-21 05:16:31 PST
tb-ta:
missing: 123
keys: 1822
unchanged: 1542
changed: 5967
missingInFiles: 13
obsolete: 77
78% of entries changed

is my output, missing strings are for non-mail parts. I suspect that you need to do a python client.py checkout to get up-to-date toolkit strings.

I don't know the full review procedures of mail, but at least toolkit/defines.inc needs to be updated, it still claims English (US) ;-). Not sure which plural rule to use, https://developer.mozilla.org/en/Localization_and_Plurals.
Comment 23 Simon Paquet [:sipaq] 2009-01-21 14:15:10 PST
Comment on attachment 357933 [details]
ta-LK l10n source files for TB3

What Pike said, although due to a recent checkin your numbers right now are:

tb-ta:
missing: 139
keys: 1822
unchanged: 1540
changed: 5962
missingInFiles: 13
obsolete: 84
77% of entries changed

From my point of view, r=sipaq
Comment 24 Sarves 2009-01-21 20:38:01 PST
Thanks Axel and Simon. We are continuing our works and we will do more. 

Review + :) how we should proceed from here?

@Pike : We will check about plural forms and do necessary changes. Also very soon we will meet with Firefox :)
Comment 25 Simon Paquet [:sipaq] 2009-01-22 06:10:26 PST
I'll land your intermediary localization once a hg repository for ta-LK has been created (see bug 474782).

I would appreciate it if you could provide me with an updated localization by the end of the weekend, which I will then land in hg.
Comment 26 Sarves 2009-01-22 11:49:10 PST
Thanks Simon, we will try our best.
Comment 27 Rohana Dasanayaka 2009-01-22 23:33:41 PST
(In reply to comment #26)
> Thanks Simon, we will try our best.

Sarves,

I managed to get the same result, that Simon got, by using "python client.py checkout" with my "compare-locale". So, we can submit better set of files today itself.

tb-ta/:
missing: 141
keys: 1822
unchanged: 1540
changed: 5960
missingInFiles: 13
obsolete: 86
77% of entries changed
Comment 28 Rohana Dasanayaka 2009-01-23 01:57:41 PST
Created attachment 358363 [details]
ta-LK l10n sorce files for TB3

Simon,

I am uploading modified Thunderbird 3 l10n files for ta-LK. We again kindly request l10-review for this. Thanks
Comment 29 Simon Paquet [:sipaq] 2009-01-23 13:58:49 PST
Comment on attachment 358363 [details]
ta-LK l10n sorce files for TB3

Looks good in general, but you still haven't fixed your localization title in toolkit/defines.inc

Here's the output that compare-locales gave me:

ta-tb
  dom/chrome/layout/css.properties
      -UseOfGetPropertyCSSValueWarning
  toolkit
    chrome/global/intl.properties
        +intl.charsetmenu.browser.unicode
    crashreporter/crashes.dtd
        -clearAllReports.label
        +clearReports.label
ta-tb:
keys: 1883
unchanged: 1454
changed: 6137
obsolete: 2
missing: 2
80% of entries changed

Please fix the defines.inc issue and do whatever you can with regards to the not yet translated strings and I'll gladly r+ this.
Comment 30 Rohana Dasanayaka 2009-01-25 03:15:15 PST
Created attachment 358698 [details]
ta-LK l10n sorce files for TB3

Simon, 

Thanks for your feedback on the above attachment. This set of files will solve the above-mentioned problems.
Comment 31 Sarves 2009-01-25 03:57:46 PST
Thanks Simon. 
Thanks Rohana, could you please set the flag of the attachment to '?'.

sarves
Comment 32 Simon Paquet [:sipaq] 2009-01-27 10:42:24 PST
Changeset b15baa06c36a pushed for http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/ta-LK/

Changeset 15d5c88f9c82 pushed for http://hg.mozilla.org/l10n-central/ta-LK/
Comment 33 Sarves 2009-01-27 15:53:09 PST
Thanks a lot Simon for pushing the ta-lk.
Comment 34 Rohana Dasanayaka 2009-02-13 03:21:18 PST
Created attachment 362202 [details]
ta-LK l10n sorce files for TB3-Beta2

Simon,

Attached files are ta-LK l10n files for TB3 Beta2. Could you pl. push this time too.
Comment 35 Simon Paquet [:sipaq] 2009-02-14 03:13:24 PST
Changeset 343cbe4202b8 was pushed to 

http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/ta-LK/
http://hg.mozilla.org/l10n-central/ta-LK/

Looking at the compare-locales output, you are still missing the following files, which were added recently:

- aboutRights.dtd
- aboutRights.properties
- activity.dtd
- activity.properties

Also many new strings were just added in their English form.
Comment 36 Sarves 2009-02-14 03:27:30 PST
Again thanks a lot for pushing. Sure we will look into this and modify soon.
Comment 37 Rohana Dasanayaka 2009-02-14 23:41:12 PST
Created attachment 362452 [details]
Missing files for ta-LK of Thunderbird3

Simon,

I am herewith attaching above-mentioned 4 files. pl. push this and help ta-LK green. Thanks.
Comment 38 Simon Paquet [:sipaq] 2009-02-17 00:52:48 PST
Changeset 985195186f31 pushed to 

http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/ta-LK/
http://hg.mozilla.org/l10n-central/ta-LK/

Rohana and Sarves,
the l10n dashboard is now green for ta-LK. I would recommend that you grab a current build for each platform that you can test and look at it thoroughly. 

If it's looking fine, then please opt-in for the TB3 b2 release in the corresponding thread in the mozilla.dev.l10n newsgroup
Comment 39 Rohana Dasanayaka 2009-02-17 01:28:34 PST
Simon,

Thanks for helping us.

ta-Lk windows build is not available in [1]

I suspect, the reason is that Tamil is not supporting Windows Code Page. If so, we need to revert the installer files. Same thing happened to "si" locale. 

[1] http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk-l10n/
Comment 40 Simon Paquet [:sipaq] 2009-02-17 02:11:30 PST
(In reply to comment #39)
> ta-Lk windows build is not available in [1]
> 
> I suspect, the reason is that Tamil is not supporting Windows Code Page. 
> If so, we need to revert the installer files. Same thing happened to "si" 
> locale.

Probably. 
Why don't you or Sarves try to fix this with your new and shiny hg privileges?
Comment 41 Rohana Dasanayaka 2009-02-17 02:25:34 PST
Simon,

My account has not yet been created. 

Could you pl. replace installer files with en-US. I promise you for not putting this work to you after this beta2.
Comment 42 Axel Hecht [:Pike] 2009-02-17 02:34:16 PST
The problem with the installer is not about the encoding, but about the variable use. Please check the latest en-US version of the installer files and make sure that the name and the format of the variables match in each string.
Comment 43 Rohana Dasanayaka 2009-02-17 02:59:34 PST
Axel, Simon

We have not translated mail/installer files, they contains en-US strings.
Comment 44 Simon Paquet [:sipaq] 2009-02-17 04:48:38 PST
Rohana,
look at the differences between what the French guys are doing and you are doing:

http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/fr/annotate/d7d675b257a0/mail/installer/override.properties vs.
http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/ta-LK/annotate/985195186f31/mail/installer/override.properties

You'll need to replace "$(^Name)" with "$BrandFullName"
Comment 45 Sarves 2009-02-17 13:47:28 PST
Oh ho :-?
Yep, Many thanks Simon. We will do the changes.

Sarves
Comment 46 Rohana Dasanayaka 2009-02-17 20:57:32 PST
Created attachment 362844 [details]
file to be placed to fix installer problem

Simon,

Identified the problem, This file should be placed by replacing the existing one in mail/installer dir. As mentioned above "variable name" was the problem. Thanks for helping us.
Comment 47 Sarves 2009-02-18 04:21:21 PST
(In reply to comment #38)
> Changeset 985195186f31 pushed to 
> 
> http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/ta-LK/
> http://hg.mozilla.org/l10n-central/ta-LK/
> 
> Rohana and Sarves,
> the l10n dashboard is now green for ta-LK. I would recommend that you grab a
> current build for each platform that you can test and look at it thoroughly. 
> 
> If it's looking fine, then please opt-in for the TB3 b2 release in the
> corresponding thread in the mozilla.dev.l10n newsgroup

Simon, 
I checked in Linux and mac, working fine. 
So once the installer problem is solved we are aredy to opt-in.
Thanks you guys
Comment 48 Simon Paquet [:sipaq] 2009-02-18 12:13:49 PST
Changeset 39908593677a pushed to 

http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/ta-LK/
http://hg.mozilla.org/l10n-central/ta-LK/
Comment 49 Sarves 2009-02-18 12:46:12 PST
Thanks Simon :)
Comment 50 Rohana Dasanayaka 2009-02-19 02:08:46 PST
We are ready to opt-in for tb3-beta2 after checking nightly build for win32. Thanks.
Comment 51 Simon Paquet [:sipaq] 2009-02-19 10:25:18 PST
Ok, please opt-in using the opt-in thread in mozilla.dev.l10n

Note You need to log in before you can comment on or make changes to this bug.