[RFE] Ability to run .exe files from webpages

VERIFIED DUPLICATE of bug 106094

Status

Core Graveyard
File Handling
--
enhancement
VERIFIED DUPLICATE of bug 106094
18 years ago
2 years ago

People

(Reporter: Ian Thomas ('thelem'), Assigned: Bill Law)

Tracking

Trunk
mozilla0.9.9
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [smartupdate])

(Reporter)

Description

18 years ago
When you click on an exe file in Internet Explorer you are presented with a 
dialog asking you if you want to open the file or save it to disk, I would like 
similar functionallity added to Mozilla.

Comment 1

18 years ago
RFE, so confirming (was unable to find a dup).   This just requires saving the 
file to a temporary folder and then executing it from there upon completion; 
it's not really "running it from the site" as IE makes it seem.  I don't know 
who would implement this, though. networking, maybe?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
so the "run" option would replace "pick app..." for certain types of files?
(Reporter)

Comment 3

18 years ago
Yes, but it is important that the file is run from its existing location.

I intend this mainly for magazine coverdisks which are increasingly using HTML. 
When they link to setup files these need to be run from the CD, as they are 
often large and may have relational links to other files on the CD.

A copy-and-run solution would be better than nothing, however. Especially if it 
would be trivial to implement.

Comment 4

18 years ago
XP Apps?

Comment 5

18 years ago
over to Networking for initial look.  Feel free to bounce it right back if this 
isnt a networking issue.  
Assignee: asa → gagan
Component: Browser-General → Networking
QA Contact: doronr → tever

Comment 6

18 years ago
ben is the one doing the UI but I think some of the recent changes with Helper 
Apps issues will resolve this. 
Assignee: gagan → ben

Comment 7

18 years ago
I think mscott said the new helper app dialog would have a run option a la IE.
(Reporter)

Comment 8

18 years ago
Tested with Netscape 6 PR3 and there was no such option. I set the helper app to 
c:/winnt/explorer.exe and got an error about a missing dll. I am running Win2k.
copying hyatt as I know he was interested in this. 
Status: NEW → ASSIGNED

Comment 10

18 years ago
*** Bug 60814 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
As talked about in bug 60814, this is an intersting feature. I'm currently 
working on it in my spare time. A few things though.

1) I don't feel this is a networking issue at all. The approach I'm taking is to 
hook into the MIME type detection, or even just the file's extention.

2) To 'Lemming'. There is no such thing as "run from current location" in 
reality. What happens is the file is downloaded to the temp directory, and then 
executed. This is what IE really does, and it's the only real way to do it 
outside of creating a native app to DL the data to RAM and execute it. You can't 
stream executable files. Well, maybe there could be a way devised to do it, but 
it doesn't happen in the same manner as media files.

For further info, read the comments from bug 60814.

Comment 12

18 years ago
Adding me to the CC lsit. Sorry for the spam. My brain isn't multitasking well 
today. Every time I try to do more than one thing at a time, the world looks 
blue, I see odd text with strange numbers, and I can't move or talk until some 
one smacks me upside the head.

Comment 13

18 years ago
IE actually can run local programs, and it doesn't copy them to the cache 
before running them.  See bug 59932 for an rfe that would let Mozilla do the 
same.

Comment 14

18 years ago
But that relates to IE's shell abilities, and is not inreality part of the 
browser. The Intergration of the two has blurred the lines, but it actualyl 
calls different libraries when browsing local disks.

Comment 15

18 years ago
*** Bug 60814 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
fwiw. On NT you can run app streams. iirc Borland's Delphi offers this 
feature.

Beyond that. I would like people to read bug 60814 before they implement 
anything. >Don't remove this dependency<
Depends on: 60814

Comment 17

18 years ago
Dupliced with 59932
And I have told that same bug is excuting exe from local disk.
But This bug will told more than only excuting exe.

Comment 18

18 years ago
Dupliced with 59932
And I have told that same bug is excuting exe from local disk.
But This bug will told more than only excuting exe.
I do this *everyday* ftom ftp://sweetlou, getting my commercial builds, I just
double click ns6setup.exe and it prompts me to Open this file or Save to Disk.
Naturally, I open this file, and it automatically runs the setup program.  Am I
missing something here?

Comment 20

18 years ago
Holy crap. I never thought to use the "Open with" without any selection. Well, 
smakc me with a large trout. Thta's half my project done. Next is a warning when 
doing this.

Comment 21

18 years ago
stephend: you're missing nothing, but everyone else is missing an intuitive UI.

Comment 22

17 years ago
This is such a useful feature, and it's already been implemented; let's not 
waste time going the extra tenth of a mile and exposing it to users.  Bill, 
what's the least hackish way to determine the extension of the filetype being 
downloaded (not having explored helper app dlg code yet)?  Matthew, can you 
offer some UI advice here?
Assignee: ben → blakeross
Status: ASSIGNED → NEW
Keywords: nsbeta1, nsCatFood
OS: Windows 95 → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9.1

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1

Updated

17 years ago
Whiteboard: [smartupdate]

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Reporter)

Comment 23

17 years ago
It should not be done by file extention, it should be done by the type of the 
data (whatever the equivilent of text/html is), if this is possible.

Most windows magazine cover disks use HTML interfaces, so people can only use 
them in IE. Adding this feature would make Mozilla seem like a better browser 
to the journalists, so they would hopefully write about it in a more positive 
light, increasing user base.

Comment 24

17 years ago
so you want us to register application/vnd.microsoft.windows.win32 and map .exe 
to that mime type? [a] we can 't do that (we aren't microsoft). [b] that's 
yucky. [c] what happens when the file really should have been 
application/vnd.microsoft.dos or application/vnd.microsoft.winnt.posix or ... 
application/vnd.unknown.dos.protectedmode ...

Assuming you don't want us to register lots of silly mime types, we'd rely on 
something like application/octetstream (* there are probably 5-20 different 
mime types all of which mean: binary, possibly executable) which could be a 
solaris sparc binary or a macos binary (*macos binaries are likely to be 
destroyed, but ...) and then we'd be doing the user a disfavor when we let them 
'run' an 'application' (which clearly won't work)
(Reporter)

Comment 25

17 years ago
Calm down, by the very fact that I put 'whatever the equivilent of text/html is
' I showed that I did not know what the status of mime types for executables
was. I was merely pointing out that using file extensions was not a perfect
method, however it may be the best method.

Comment 26

17 years ago
I think that we must added feature: EXE-files will be checked by Virusscan 
before exe-files will be executed. It can be warn that it's not tested by 
virusscan. Do you want to scan this file for unknown virus?

Comment 27

17 years ago
While I should have noted a long time ago I am currently unable to contribute 
code, I feel the need to adda reply now. When you say Virus Scan, are you 
meaning the name of an actual product, or just virus scanners in general? No two 
programs use the same format for command arguments, etc. But also, many good 
scanners scan files upon execution I use Norton, and it scans EXEs automatically 
upon the program being launched. I see no need to double up there.

Comment 28

17 years ago
you can select one of scanners. This feature that you can switch : scan this 
file or block EXE for Security.
It can used for exes from internet. but it will not for exes from localhost.

Comment 29

17 years ago
Please address virus scanning in a seperate bug. AIM does offer virusscanning 
support in its interface but that is _FAR_ beyond the scope of this bug.

Comment 30

17 years ago
Open Networking bugs, qa=tever -> qa to me.
QA Contact: tever → benc

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Updated

17 years ago
Priority: P1 → --
Target Milestone: mozilla0.9.3 → mozilla1.0

Comment 31

17 years ago
usability/polish, 0.9.4.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.0 → mozilla0.9.4
(Reporter)

Comment 32

17 years ago
Are you sure? This doesn't look fixed to me...

Comment 33

17 years ago
Hit the wrong button...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

17 years ago
Status: REOPENED → ASSIGNED

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

17 years ago
Blocks: 104166

Comment 34

17 years ago
law has this item, i believe.
Assignee: blakeross → law
Status: ASSIGNED → NEW
Target Milestone: mozilla0.9.6 → ---
(Assignee)

Comment 35

17 years ago
*** Bug 102760 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 36

17 years ago
->mozilla0.9.9
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 37

17 years ago
yes, I know this bug predates that one by a lot, but that's the bug we created 
for this feature in MachV

*** This bug has been marked as a duplicate of 106094 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED

Comment 39

17 years ago
->file handling w/ qa.
Component: Networking → File Handling
QA Contact: benc → sairuh

Updated

17 years ago
Depends on: 106094
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.