Enable shift + drag for folders in bookmarks toolbar on Linux

VERIFIED FIXED in Firefox 3.1b1

Status

()

VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: ojab, Assigned: mak)

Tracking

Trunk
Firefox 3.1b1
x86
Linux
Points:
---
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b4pre) Gecko/2008022921 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b4pre) Gecko/2008022921 Minefield/3.0b4pre

When I'm trying to drag folder, it opens like I've clicked.

Reproducible: Always

Steps to Reproduce:
1. Create folder on bookmarks toolbar.
2. Try to drag it.
Actual Results:  
It opens.

Expected Results:  
Should be pressed as any other bookmark to be able move it.

Updated

11 years ago
Version: unspecified → Trunk
Shift+drag works on Windows. Not on Linux?
Component: Bookmarks → Places
QA Contact: bookmarks → places
(Reporter)

Comment 2

11 years ago
Nope, on my system shift+drag also opens folder.
(Assignee)

Comment 3

11 years ago
dragging folders does not work on linux. confirming (but maybe there are dupes around, surely there is a bug for mac filled)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

11 years ago
You can't drag folders or feeds in the bookmarks toolbar in Fx3rc1 on Mac 10.5.2. Using shift, command, or control in addition to mouse click does not help. Bug 404214 mentions making this work with the cmd key. 
(Assignee)

Comment 5

11 years ago
IIRC there's another bug about restore dragging with cmd drag or shift drag for Mac... that is old
(Assignee)

Comment 6

11 years ago
Mac bug is bug 389914
(Assignee)

Comment 7

10 years ago
Can someone on Linux check if this is fixed on 20080920033605 nightly build?
Depends on: 418671
Summary: Can't move folders on bookmark toolbar → Can't drag folders on bookmark toolbar
(Assignee)

Comment 8

10 years ago
PS: you should use shift+drag for folders on the toolbar like on other platforms
(Assignee)

Updated

10 years ago
Summary: Can't drag folders on bookmark toolbar → Enable shift + drag for folders in bookmarks toolbar on Linux
Target Milestone: --- → Firefox 3.1b1
(Assignee)

Comment 9

10 years ago
Created attachment 339757 [details] [diff] [review]
fix typo

followup to bug 418671, stupid typo :\
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #339757 - Flags: review?(mano)
(Assignee)

Comment 11

10 years ago
http://hg.mozilla.org/mozilla-central/rev/920a4326d108
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

10 years ago
actually the problem was due to the fact the popupshowing was dismissing the drag start, so we preventDefault() on popupShowing if the user is holding the shift key.

Comment 13

10 years ago
Verified fix on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20081006 Minefield/3.1b1pre
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Duplicate of this bug: 433490
As Marco pointed out on IRC we don't have d&d tests yet. Means, we should add this d&d behavior as a testcase on Litmus.
Flags: in-litmus?
Test case https://litmus.mozilla.org/show_test.cgi?id=7454 was updated in its expected results to take this bug into account for regression testing.
Flags: in-litmus? → in-litmus+
Huh, Marco I have a question. Haven't we removed the need of using the shift key for dragging folders on the toolbar for each OS now?
(Assignee)

Comment 18

10 years ago
(In reply to comment #17)
> Huh, Marco I have a question. Haven't we removed the need of using the shift
> key for dragging folders on the toolbar for each OS now?

only on trunk
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.