All users were logged out of Bugzilla on October 13th, 2018

E-mail address is split by mistake when quotation marks are omitted

RESOLVED DUPLICATE of bug 254519

Status

RESOLVED DUPLICATE of bug 254519
11 years ago
11 years ago

People

(Reporter: minimax, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 2.0.0.12 (20080213)

This form of "From:"-line in e-mail:

From: =?iso-8859-2?Q?Ing._Lubom=EDr_Kuchynka=2C_Tepeln=E1_=E8erpadla_AC_Heating?= <LKuchynka@ac-heating.cz>

is unfortunately interpreted as two e-mail addresses because of the char "2C" (comma) involved and quotation marks (22) omitted.

It is not possible to reply to such an e-mail because Thunderbird adds two addressees into the compose form which are naturally not valid.

Reproducible: Always

Steps to Reproduce:
1. Receive an e-mail which contains the line cited above or a similar one without quotation marks.
2. Try to reply to such an e-mail.
3. Thunderbird thinks it should reply to two addresses simultaneously.
Actual Results:  
Wrong interpretation of one address.

Expected Results:  
Right interpretation of the address even if the quotation marks are missing.
DUP of longlived Bug 254519.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
You need to log in before you can comment on or make changes to this bug.