ProfileMigrator's GetDefaultBrowser does not work any more on Vista

VERIFIED FIXED in Firefox 14

Status

()

Firefox
Migration
VERIFIED FIXED
10 years ago
5 years ago

People

(Reporter: Bruno Calvignac, Assigned: mano)

Tracking

2.0 Branch
Firefox 15
x86
Windows Vista
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified)

Details

(Whiteboard: [qa+:paul.silaghi])

Attachments

(1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080227 Firefox/2.0.0.12 Flock/1.1e
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080227 Firefox/2.0.0.12 Flock/1.1e

As of January 2008, Vista does not (cannot) use HTTP\\shell\\open\\command any more and the above function does not determine correctly the default browser. I can only think that this is caused by a Windows Update.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
The consequence is that Microsoft Internet Explorer is always selected in the profile migrator, even if your default browser was set to something else (e.g Opera)
(Reporter)

Comment 1

10 years ago
Created attachment 307297 [details] [diff] [review]
fix
Bruno, do you want to get this patch checked in?
(Reporter)

Comment 3

8 years ago
Yes, we have it checked in in our Flock code.

Updated

6 years ago
Version: unspecified → 2.0 Branch
I'm working on this code, the patch was never checked in.
But now this works with Windows 7.
Assignee: nobody → mano
Status: UNCONFIRMED → ASSIGNED
Depends on: 715099
Ever confirmed: true
Depends on: 748569
Summary: nsProfileMigrator::GetDefaultBrowserMigratorKey does not work any more on Vista → ProfileMigrator's GetDefaultBrowser does not work any more on Vista
Fixed by bug 748569.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox14: --- → fixed
Target Milestone: --- → Firefox 15

Updated

5 years ago
Attachment #307297 - Attachment is obsolete: true
Isn't this a dupe of bug 262326 ?
No...
The default browser is correctly selected on initial Migration Wizard on Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0b8. Verified fixed.
Status: RESOLVED → VERIFIED
status-firefox14: fixed → verified
Whiteboard: [qa+:paul.silaghi]
You need to log in before you can comment on or make changes to this bug.