Last Comment Bug 420938 - ProfileMigrator's GetDefaultBrowser does not work any more on Vista
: ProfileMigrator's GetDefaultBrowser does not work any more on Vista
Status: VERIFIED FIXED
[qa+:paul.silaghi]
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: 2.0 Branch
: x86 Windows Vista
: -- normal (vote)
: Firefox 15
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
:
Mentors:
Depends on: 715099 748569
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 13:09 PST by Bruno Calvignac
Modified: 2012-06-22 04:48 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified


Attachments
fix (5.03 KB, patch)
2008-03-04 13:13 PST, Bruno Calvignac
no flags Details | Diff | Splinter Review

Description Bruno Calvignac 2008-03-04 13:09:46 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080227 Firefox/2.0.0.12 Flock/1.1e
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080227 Firefox/2.0.0.12 Flock/1.1e

As of January 2008, Vista does not (cannot) use HTTP\\shell\\open\\command any more and the above function does not determine correctly the default browser. I can only think that this is caused by a Windows Update.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
The consequence is that Microsoft Internet Explorer is always selected in the profile migrator, even if your default browser was set to something else (e.g Opera)
Comment 1 Bruno Calvignac 2008-03-04 13:13:44 PST
Created attachment 307297 [details] [diff] [review]
fix
Comment 2 Wayne Mery (:wsmwk, NI for questions) 2009-05-12 05:56:25 PDT
Bruno, do you want to get this patch checked in?
Comment 3 Bruno Calvignac 2009-05-12 08:24:26 PDT
Yes, we have it checked in in our Flock code.
Comment 4 Marco Castelluccio [:marco] 2011-08-19 16:53:00 PDT
I'm working on this code, the patch was never checked in.
But now this works with Windows 7.
Comment 5 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-05-29 12:12:03 PDT
Fixed by bug 748569.
Comment 6 Paul Silaghi, QA [:pauly] 2012-06-21 07:27:32 PDT
Isn't this a dupe of bug 262326 ?
Comment 7 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-06-21 16:23:16 PDT
No...
Comment 8 Paul Silaghi, QA [:pauly] 2012-06-22 04:48:56 PDT
The default browser is correctly selected on initial Migration Wizard on Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0b8. Verified fixed.

Note You need to log in before you can comment on or make changes to this bug.