Provide list view for attachements

RESOLVED DUPLICATE of bug 360647

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 360647
10 years ago
7 years ago

People

(Reporter: Oliver Fischer, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Version 2.0.0.12 (20080213)

If I am not mistaken, thunderbird displays attachements currently only as icons in a grid. Sometimes I get mails with a lot of attachments (> 30). This way of displaying the attachments takes a lot space and sometime are the filenames 	truncated. 

Because of this, I would like to have the possibility to display the attachments as table with three columns:

1. Icon for the file type of the attachment.
2. filename
3. filesize

It would be great if you could provide an option to display the attachments in this way.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

8 years ago
I agree that this is a problem. I've got some e-mails with a dozen or so attachments, each one with a filename that starts and ends very similar. It's difficult to determine which one is which without downloading them all, because I have to hover over each one. They're sorted left-to-right alphabetically (not sure if that's due to the sender or Thunderbird sorting them).

It would be nice to have an optional list or detail view so I could sort them by size, view the full file name, and be able to copy the filename to clipboard.

This view would have to have a vertical scroll bar so it doesn't take too much space, as with the headers when a message has a long list of recipients.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360647
You need to log in before you can comment on or make changes to this bug.