Closed Bug 421574 Opened 12 years ago Closed 12 years ago

Sunbird static build fails due to missing BeOS bindings

Categories

(Calendar :: Build Config, defect, major)

x86
BeOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: doug, Assigned: doug)

Details

(Keywords: fixed1.8.1.13)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.8.1.13pre) Gecko/20080307 BonEcho/2.0.0.13pre
Build Identifier: 

needs -ltracker and -lgame in application makefile.  similar changes were already committed for Firefox and Thunderbird.

Reproducible: Always
Status: NEW → ASSIGNED
Version: unspecified → Mozilla 1.8 Branch
What are the corresponding bugs for Firefox and Thunderbird? Knowing them would be useful here.
Corresponding bugs are bug 314518 (browser) and 397116 (mail)
Make that Corresponding bugs are bug 314518 (browser) and bug 397116 (mail).
Uses same format as Firefox and Thunderbird patches.
Attachment #308153 - Flags: review?(sergei_d)
Comment on attachment 308153 [details] [diff] [review]
Adds correct libs to sunbird makefile for static builds

r
Attachment #308153 - Flags: review?(sergei_d) → review+
Comment on attachment 308153 [details] [diff] [review]
Adds correct libs to sunbird makefile for static builds

Thanks, Sergei.  Requesting approval to land on 1.8 branch.
Attachment #308153 - Flags: approval1.8.1.13?
Comment on attachment 308153 [details] [diff] [review]
Adds correct libs to sunbird makefile for static builds

You don't need branch approval for stuff in mozilla/calendar as we have a strict cross-commit policy to both trunk and 1.8 branch. So does the same fix need to be applied to the trunk as well?

What you need however, is an additional review of our build config owner.
Attachment #308153 - Flags: approval1.8.1.13? → review?(ause)
Assignee: nobody → doug
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Thank you, Simon, for requesting the additional review.  Because of gcc limitations (BeOS only supports 2.95.3) and dependencies, we are not able to build the trunk, however this should definitely be committed to the trunk as well.
Comment on attachment 308153 [details] [diff] [review]
Adds correct libs to sunbird makefile for static builds

should not interfere with other platforms
Attachment #308153 - Flags: review?(ause) → review+
thank you for the review.  Sergei, will you be able to commit this to branch and trunk? 
(In reply to comment #10)
> thank you for the review.  Sergei, will you be able to commit this to branch
> and trunk? 
> 
will do ASAP
trunk:
Checking in mozilla/calendar/sunbird/app/Makefile.in;
/cvsroot/mozilla/calendar/sunbird/app/Makefile.in,v  <--  Makefile.in
new revision: 1.59; previous revision: 1.58
done 
MOZILLA_1_8_BRANCH:
Checking in mozilla/calendar/sunbird/app/Makefile.in;
/cvsroot/mozilla/calendar/sunbird/app/Makefile.in,v  <--  Makefile.in
new revision: 1.21.2.22; previous revision: 1.21.2.21
done 
Keywords: fixed1.8.1.13
Patch has been checked in over a month ago. Can we resolve the bug as FIXED?
(In reply to comment #14)
> Patch has been checked in over a month ago. Can we resolve the bug as FIXED?

No response. Marking FIXED.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Version: Mozilla 1.8 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.