filename of download progress dialog is incorrect

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

18 years ago
ENVIRONMENT
===========
All platfoem's Mozilla 2000-06-11

REPRO STEP
==========
1. browse this URL
2. set JPN folder, and click [OK] (ex. C:\テスト)

RESULT
======
It is displayed incorrect folder in [saving to] editbox

DESCRIPTION
===========
I wrote Content-Disposition' patch of bug 22861.  This fix is inclued in this 
patch.  But law doesn't include...
(Assignee)

Comment 1

18 years ago
Sorry, rewrite produce step.

REPRO STEP
==========
1. browse this URL
2. displayed [Unknown File Type] dialog
3. click [Save File...]
4. displayed [Save File] dialog
5. select JPN folder name (ex. C:\テスト)
6. click [OK]
7. dispalyed [Saving file] progress dialog

RESULT
======
[C:\?e?X?g\fm._$$] is displayed in [to:] editbox

Comment 2

18 years ago
can verify this happens for me. Also, when I paste the path name suggested into
the "save as.." dialog, the letters that are replaced by "?"s in the saving
progress box are instead those black bars typical of a missing character in a
font. Perhaps this is a font issue then?
(Assignee)

Comment 3

18 years ago
This isn't font issue.
This is bad cast issue from string to wstring.

Comment 4

18 years ago
bill law- can you handle this. CC nhotta since forfile path issue.
Assignee: ftang → law
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Yes, I'll look into fixing this.
Status: NEW → ASSIGNED

Comment 6

18 years ago
*** Bug 43487 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
Created attachment 10898 [details] [diff] [review]
a patch
(Assignee)

Comment 8

18 years ago
law, if you have no time, please assign to me.

Comment 9

18 years ago
It's not that I have *no* time; just not enough.  Your help on this would be 
greatly appreciated.
Assignee: law → m_kato
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 10

18 years ago
Created attachment 15989 [details] [diff] [review]
fix code

Comment 11

18 years ago
Thanks.  I will roll that fix into my patches to those files for other bugs (bug
35161, et al).

Comment 12

18 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong
(Assignee)

Comment 13

18 years ago
Ccing Katakai-san due to bug 60941

Comment 14

18 years ago
I think this bug was fixed. 2000122204/Win98 works fine.

Comment 15

18 years ago
The bug still exists in Mtrunk 12-26 build/WinME-JPN.
(Assignee)

Comment 16

18 years ago
check in by law
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
On 03-29 trunk build, the Japanese directory name display fine and the file name 
shows: fm._$$
I'll mark it as verified.  Please re-open it if disagree.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.