Closed Bug 421952 Opened 13 years ago Closed 13 years ago

replying to e-mail having from address in quoted-printable form with commas mangles the address

Categories

(Thunderbird :: Message Compose Window, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: jojo, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.1.5) Gecko/20070722 Firefox/2.0.0.5
Build Identifier: version 2.0.0.5 (20070721)

When you reply to an e-mail that has the name in the From address encoded in Quoted-printable form and it also contains commas Thunderbird mangles the address. Example:

From: =?iso-8859-2?Q?Cerny=2C_Mari=E1n=2C_CZ?= <marian.cerny@example.org>

Which decoded should be something like:

From: "Cerny, Marian, CZ" <marian.cerny@example.org>

However Thunderbird decodes the address into something like:

From: Cerny, Marian, CZ <marian.cerny@example.org>

And when you reply to it, it tries to send message to three addresses:

To: Cerny
To: Marian
To: CZ <marian.cerny@example.org>

Reproducible: Always

Steps to Reproduce:
1. text-edit a message on a server and change From: field to =?iso-8859-2?Q?Cerny=2C_Mari=E1n=2C_CZ?= <marian.cerny@example.org>
2. reply to such message in Thunderbird
Actual Results:  
Thunderbird will try to send the reply to 3 addresses -
To: Cerny
To: Marian
To: CZ <marian.cerny@example.org>

Expected Results:  
Thunderbird should reply to one address:
To: "Cerny, Marian, CZ" <marian.cerny@example.org>

I am receiving such messages from MS Exchange:

X-MimeOLE: Produced By Microsoft Exchange V6.5
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
You need to log in before you can comment on or make changes to this bug.