Deleting some addresses in the history of the address bar doesn't work sometimes

RESOLVED DUPLICATE of bug 415397

Status

()

RESOLVED DUPLICATE of bug 415397
11 years ago
10 years ago

People

(Reporter: yam90, Unassigned)

Tracking

({privacy, regression})

Trunk
privacy, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

http://search.yahoo.com/search?ei=utf-8&fr=megaup&p==71
I'm trying to delete this link, but it wont go i select it by the arrows and press del, it still won't delete

Reproducible: Always

Steps to Reproduce:
1. add http://search.yahoo.com/search?ei=utf-8&fr=megaup&p==71 in the address bar
2. select it by the arrows
3. press DEL
4. repeat
Actual Results:  
Nothing. the URL refuses to get removed

Expected Results:  
Delete the URL

Comment 1

11 years ago
I can confirm this, but it's necessary to perform the search on the results page mentioned in this bug again. This bug also happens for the results pages from the mozillazine forums search through google.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031014 Minefield/3.0b5pre

Regression range:
2008020102 works
2008020115 fails

Bonsai query:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2008-02-01+02&maxdate=2008-02-01+15%3A59%3A59
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031012 Minefield/3.0b5pre ID:2008031012

Confirming, I've reproduced the problem on a new profile. Nominating for blocking since this represents a possible privacy issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Keywords: privacy
Version: unspecified → Trunk
Works: 20080201_0118_firefox-3.0b3pre.en-US.win32
Broken: 20080201_0852_firefox-3.0b3pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-02-01 01:18 and 2008-02-01 08:52 :
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-02-01+01%3A18&maxdate=2008-02-01+08%3A52&cvsroot=%2Fcvsroot

Due to bug 413784 or bug 407974
Keywords: regression

Updated

11 years ago
Blocks: 407974
Bah, this is probably a dupe of bug 415397 right?
This WFM on this build which includes the patch for bug 419656.

(I do see the problem on trunk when you load that page and click "Search" again.)

https://build.mozilla.org/tryserver-builds/2008-03-10_16:54-edward.lee@engineering.uiuc.edu-keyword.special.update/
Depends on: 419656
OS: Windows Server 2003 → All
Hardware: PC → All
Yeah, this also WFM on the 2008-03-10_16:54-edward.lee-keyword.special.update/ build.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415397
Flags: blocking-firefox3?

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.