RealPlayer Browser Record Plugin extension causes all sorts of problems in Firefox

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
10 years ago
a year ago

People

(Reporter: Jason Barnabe (np), Unassigned)

Tracking

({common-issue+})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
RealPlayer Browser Record Plugin (an extension, despite the name) is installed into Firefox when you install RealPlayer. It causes a variety of problems. Can we engage Real and get them to fix this up? If they update it (and perhaps if they don't), can we add it to the extension block list?

Here are categorized instances of people confirming that disabling or uninstalling this extension solved their problem:


Crash:
http://real.lithium.com/real/board/message?board.id=realplayer&message.id=15748
https://bugzilla.mozilla.org/show_bug.cgi?id=418232
http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=3492#threadId23668
http://discuss.joyent.com/viewtopic.php?pid=171118

Hang:
http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=19313

Causing problems with images/Flash:
http://real.lithium.com/real/board/message?board.id=realplayer&message.id=20718
http://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=2999&forumId=1
http://forums.mozillazine.org/viewtopic.php?t=631499
http://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=2999&forumId=1
http://www.mac-dev.net/blog/forum/flv-player-forum/topic-45/
http://www.piclens.com/site/support/realplayer.php

Causing problems with forms and back/forward:
http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=12697
http://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=7441&forumId=1
http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=18506
http://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=8008&forumId=1
http://forums.mozillazine.org/viewtopic.php?t=600020
http://forums.mozillazine.org/viewtopic.php?t=612043
http://forums.mozillazine.org/viewtopic.php?t=624663

Causing problems with forms and autocomplete:
http://forums.mozillazine.org/viewtopic.php?t=617971
http://forums.mozillazine.org/viewtopic.php?t=622847
(Reporter)

Comment 1

10 years ago
Alex, Chris, is this a candidate for the block list?

Comment 2

10 years ago
we need to do a lot more investigation before moving forward.  the blocklisting is only for firefox 3.   I followed links from the "crash section" listed above and that sounds like a problem that affects firefox 2, and has been fixed in firefox 3, so it doesn't appear that we would block for that.

for firefox 3 we also need specific versions info for both the plugin and firefox versions that are incompatible so we can target the blocking with as fine a precision as possible.

Comment 3

10 years ago
It has NEVER crashed my Firefox 2.x, and now it's disabled in firefox 3. I want it back, how can I enable it?

Comment 4

10 years ago
How can I uninstall this plugin ?

As it is not working with Ff3 I'd like to get rid of it.

Comment 5

10 years ago
It is annoying me! where is the Adobe Flash Player gone?

Comment 6

10 years ago
ive never had a problem with realplayer extension until i downloaded version 2.0.0.18 before that ive never had a problem now i cant get into my aim mailbox unless it is disabled

Comment 7

10 years ago
(In reply to comment #6)
> ive never had a problem with realplayer extension until i downloaded version
> 2.0.0.18 before that ive never had a problem now i cant get into my aim mailbox
> unless it is disabled

acctually if you increase the cache to 75 from 50 it works fine

Updated

10 years ago
Duplicate of this bug: 465875
(In reply to comment #2)
> we need to do a lot more investigation before moving forward.  the blocklisting
> is only for firefox 3.   I followed links from the "crash section" listed above
> and that sounds like a problem that affects firefox 2, and has been fixed in
> firefox 3, so it doesn't appear that we would block for that.
> 
> for firefox 3 we also need specific versions info for both the plugin and
> firefox versions that are incompatible so we can target the blocking with as
> fine a precision as possible.

Jason says it is an extension not a plugin, so we can block it in Firefox 2 if we choose to do so. We would of course still need specific versions to be able to do this.

Comment 11

10 years ago
Some additional comments regarding bug 465875, that was marked as a duplicate of this bug:
1. This affects new Yahoo! Mail (ajax version)
2. This issue started after users upgraded to FF 2.0.0.18 (win)
3. The RealPlayer component was already installed before the upgrade to FF 2.0.0.18 (don't know yet if this is critical to repro)
4. Running Fiddler shows that after Yahoo! mail starts up in the browser, it makes requests for data to the middle tier and the responses are successfully returned back to the browser, but the response handlers are not triggered.  To the end user, the UI appears but performing actions that require retrieving data from the backend appear to either hang or fail

There are now two confirmed cases where disabling the RealPlayer component immediately fixed the problem and reenabling the component reintroduced the problem, but there are several reports of this problem in the field
That forum thread seems to indicate that there's a way to update the plugin so that it works properly with Firefox 3 - has anyone tried to see if that makes things works with Yahoo! Mail, too?
We've reopened bug 465875. It may yet turn out to be the same but something seems to have gotten worse after the 2.0.0.18 release; there may be two separate problems here. If they turn out to be the same thing (maybe a race condition made worse by some minor timing change in 2.0.0.18?) we can re-dupe later.
Created attachment 349314 [details]
screenshot of my client, which appears to be the new AJAX one.

Comment 15

10 years ago
On my computer the Plugin worked very well until I installed Firefox 3.X
This has become common again in recent weeks on SUMO.  Several users have reported that, with Real Player Browser Record Plugin 1.0 installed in Firefox 3.5.3, many websites will become blank with a white or gray screen after the site finishes loading.

Some sample chats are available here (mpt-vpn access required):
http://10.2.74.133/cgi-bin/zzxc/chatquery.php?tags=realplayerbrowserrecordplugin
http://10.2.74.133/cgi-bin/zzxc/chatquery.php?tags=blank
Keywords: common-issue+

Comment 17

9 years ago
kev, do we still have a good real contact?  maybe this is connected to a real update...  this says no updates for over a year but that can't be right...
http://service.real.com/realplayer/security/en/

Comment 18

9 years ago
secunia also has nothing recent for updates on RP 11 -- latest was back in feb.
http://secunia.com/advisories/product/16937/?task=advisories_2009

Comment 19

9 years ago
my old contacts there have gone silent. I'll do some digging and see if we can get a hold of the current program/product manager.

Updated

9 years ago
Blocks: 522577
Several users on SUMO have mentioned that this extension stopped downloading videos after updating to 3.5.4.  Some 3.5.4 users are still reporting the blank page issue with it, as well.

The page blanking issue seems to be sporadic, with a large number of popular sites blanked after loading.

Comment 21

8 years ago
I just finished helping an user who reportedly could not get this plugin to work with Firefox 3.6.4, even on a new profile. I believe this is because this plugin does not know where Flash is anymore. Is it possible that it's something we can fix from our side?

Comment 22

8 years ago
And can someone please replicate this? If this is a widespread issue, I'm sure we'll want to look into it.
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX

Comment 24

a year ago
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #23)
> I'm marking this bug as WONTFIX per bug #1269807.
> 
> For more information see -
> https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/

This bug refers to the RealPlayer Browser Record Plugin EXTENSION, not NPAPI plugin so the bug report and blog post don't apply. In any case, "RealPlayer Browser Record Plugin extension causes all sorts of problems in Firefox" is probably too broad and I would suggest that new bugs be filed for any current, specific issues caused by this extension.  For example, recent versions of this extension have been blocklisted for crash issues (bug 1170633).
You need to log in before you can comment on or make changes to this bug.