If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Blocklist RealPlayer Browser Record Plugin

RESOLVED WONTFIX

Status

()

Toolkit
Blocklisting
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: Cww, Assigned: kev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

722.52 KB, text/plain
Details
(Reporter)

Description

8 years ago
The latest version of the RealPlayer Browser Record Plugin causes pages to go blank after they load.  If we can't get this fixed on their end, we'll probably have to blocklist.  Unfortunately, they don't version number (all of the extensions are numbered 1.0) so we'll have to blocklist all of them.

Comment 1

8 years ago
Generally we'd want them to fix the problem and then blocklist all the old versions, so we'd need to contact them and make sure they put a new version number in the new version with the fix.
kev, 

any luck contacting them?
(Reporter)

Comment 3

8 years ago
see also bug 422290

Updated

8 years ago
Depends on: 422290
(Assignee)

Comment 4

8 years ago
Apologies, my bad here. I did hear back, and need to follow-up.

Do we have any cases where we can repro every time, or is it an intermittent issue?
Lots of details in bug 4222290.

We should at least get them to add version numbers.  Could we do that, Kev?
Assignee: nobody → kev
(Assignee)

Comment 6

8 years ago
Per Real, the browser record add-on has been updated on a regular basis, with the latest version incorporating fixes for 3.5.4. While there have been updates, the versioning information of the add-on has not been incremented, only the build numbers of nprpffbrowserrecordext.dll (in C:\Program Files\Real\RealPlayer\browserrecord\firefox\ext\components), which is currently 1.0.1.525. The product team has taken note that they need to better version the extension, so I am hoping that will begin to happen with future releases.

The product team has also asked for additional information on issues that continue to arise, as they believe they have addressed any compatibility/rendering problems. Unfortunately, the only way to update the add-on is through a Real Player update, so that will have to be the recommended fix once we clarify if the issues we're seeing are addressed by the latest version of the add-on.
(Assignee)

Comment 7

8 years ago
and, because I forgot to add it in comment #6, I'd like to understand if this is still considered a blocklist contender. do we have any idea how many users this is potentially affecting, and does it make more sense to update SUMO to include additional information about the plugin and potential issues (there are currently no relevant entries when I search for "Real Player Browser Recorder") than blocklist? 

morgamic raised a valid concern in another thread that it makes sense to limit the number of add-ons we blocklist, and on further review I'm not sure there's enough info to determine whether or not this is a good blocklist candidate.
Going to WONTFIX this.  Reopen if this still needs to be blocklisted.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Comment 9

5 years ago
Created attachment 635836 [details]
realplayer

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: 

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: 

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: 
Fix Landed on Version:
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: 

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #635836 - Flags: approval1.9.2.28?
Attachment #635836 - Flags: approval-mozilla-release?
Attachment #635836 - Flags: approval-mozilla-esr10?
Attachment #635836 - Flags: approval-mozilla-beta?
Attachment #635836 - Flags: approval-mozilla-aurora?
Attachment #635836 - Flags: approval1.9.2.28?
Attachment #635836 - Flags: approval-mozilla-release?
Attachment #635836 - Flags: approval-mozilla-esr10?
Attachment #635836 - Flags: approval-mozilla-beta?
Attachment #635836 - Flags: approval-mozilla-aurora?
grace45230@hotmail.com: Stop spamming this production Bugzilla installation or your Account will be banned.
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.