Closed Bug 422585 Opened 14 years ago Closed 14 years ago

DM helper app dialog's initDialog() can fail

Categories

(Toolkit :: Downloads API, defect, P2)

x86
macOS
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: Dolske, Assigned: Dolske)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Attached patch Patch v.1Splinter Review
Found via bug 299372. 

* Go to http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
* Click the .dmg, this dialog is normal
* Click the .msg, this dialog is similar but has and empty dropdown element at the bottom.

There's also an error message in the console:

Error: this.mDialog.document.getButton is not a function
Source File: file:///Applications/Minefield.app/Contents/MacOS/components/nsHelperAppDlg.js
Line: 380

Looks like just a typo, the fix is trivial.
Flags: blocking-firefox3?
Comment on attachment 309034 [details] [diff] [review]
Patch v.1

r=sdwilsh, assuming you generate a test case that would fail before this patch is applied.
Attachment #309034 - Flags: review+
hrm, maybe bug 422464?
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
(In reply to comment #2)
> hrm, maybe bug 422464?

Yes, that's exactly what I was seeing.

(In reply to comment #1)
> r=sdwilsh, assuming you generate a test case that would fail before this patch
> is applied.

Hey, I'm just politely suggesting the obvious fix. No habla DM testa! :-)

This was a regression from the checkin of bug 420595. Which, I'll note, had no tests. I nominate _FrnchFrgg_ for writing a test, and/or a backout of 420595 until such a test exists. Or just treat this as an "oops", fix it, and move on.
Blocks: 420595
Duplicate of this bug: 422464
(In reply to comment #3)
> Hey, I'm just politely suggesting the obvious fix. No habla DM testa! :-)
Fair - let's do the backout to fix this bug, and that way I'm more likely to get the test too.

r=sdwilsh on the backout.
Assignee: nobody → dolske
Fixed by backing out 420595.

Don't you dare ask for a test to verify the backout. :P
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Verified FIXED using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050904 Minefield/3.0pre
Status: RESOLVED → VERIFIED
Depends on: 442463
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.