Closed Bug 422796 Opened 13 years ago Closed 13 years ago

words are not bolded/italized/underscored when they start or end with a polish diacritic letter

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 106028

People

(Reporter: fisz83, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12 Mnenhy/0.7.5.0
Build Identifier: Thunderbird 3.0a1pre (2008031302)

When a text in a message is surrounded by * *, / /, or _ _, normally it appears as bolded, italicized or underscored when viewed. However, if the first letter after the opening */_ or the last one before the closing character is one of the polish diacritics character, the style is not applied. On the attached screenshot, line 1 and 4 are correct, line 2 and 3 are not. It happens both in the ISO-8859-2 and UTF-8 encodings.

Reproducible: Always

Steps to Reproduce:
1. On a fresh profile, create a dummy pop3 account so that you can write a mesage.
2. Dstable that account preference to compose in html (that is switch to plain text).
3. Compose new message and write for example *ładny*.
4. Close the message and save it as draft, and then open it in a preview window.
Actual Results:  
The text doesn't appear to be bolded.


I have tested only the polish diacritics, that is ą ć ę ł ń ó ś ź ż. Thunderbird 2 is also affected.
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 106028
You need to log in before you can comment on or make changes to this bug.