Add gzipping to css & js files on amo (and other mozilla websites)

VERIFIED DUPLICATE of bug 441124

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED DUPLICATE of bug 441124
10 years ago
2 years ago

People

(Reporter: rdoherty, Assigned: Brian Krausz)

Tracking

Details

(Reporter)

Description

10 years ago
I was watching traffic for amo and noticed we gzip html, but not css or js.

gzipping more content would reduce the amount of bandwidth we use considerably and speed up render and download times for our users. 

http://developer.yahoo.com/performance/rules.html#gzip
Hot, yeah; we did this at AOL on the my.aol.com platform with huge wins as well.
(Reporter)

Comment 2

10 years ago
After we get gzip working, we could also set far-future expires headers (2 years min) on all static content (css, js & images). That will also cut down on bandwidth.
(Reporter)

Updated

10 years ago
Blocks: 424187
(Assignee)

Comment 3

10 years ago
Taking this, will begin work on it next week.
Assignee: nobody → bkrausz
(Assignee)

Comment 4

10 years ago
CCing Wil, Laura thinks this is not done already because our netscaler won't cache it...can you confirm?
(In reply to comment #4)
> CCing Wil, Laura thinks this is not done already because our netscaler won't
> cache it...can you confirm?
> 

I can't - I don't know the status of how that works.  We're dealing with the same problem in bug 441124
(Assignee)

Comment 6

10 years ago
This is already being investigated in another bug, marking DUP
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441124
Verified dup
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.