Closed Bug 422959 Opened 13 years ago Closed 13 years ago

Improve look and feel for BACK and FORWARD buttons

Categories

(Firefox :: Toolbars and Customization, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

()

VERIFIED WONTFIX

People

(Reporter: masonb, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.15
Build Identifier: 3.0b4

The back forward button is perhaps the single ugliest UI element I have ever seen. Ever. On any platform. That includes all types of Linux and also Windows 3.1. Even a tiny baby would know that that button should not exist. I really don't know what possessed somebody to create such a thing, were they on drugs or what? By creating that button, the Mozilla team has really made the world a measurably worse place, and for the sake of all humanity I hope it goes away very very soon.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox.
2. Look at back/forward button.
3. Hurl violently.
Actual Results:  
I managed to keep my lunch down, thank god.

Expected Results:  
It should have looked like it was created by some other means than closing your eyes, creating a few shapes in photoshop and then overlapping them...
WFM on Linux with Mozilla/5.0 (X11; U; Linux i686; eo; rv:1.9b5pre) Gecko/2008031404 Minefield/3.0b5pre
Duplicate of this bug: 422529
Flags: blocking-firefox3?
Alias: goodgod
Version: unspecified → Trunk
I DRIVE A DODGE STRATUS!
Version: Trunk → unspecified
Shoot, someone on digg called for me to be fired.  Mike: did you want me to finish up Firefox 3 first before I resign from the team to spend more time with my family?

>The back forward button is perhaps the single ugliest UI element I have ever
>seen.

Ha, take that purple java swing scroll bars, you might have thought you had a pretty strong hold on the title with all your little ridges, but YOU LOSE!  
There's no actual critique here, and the new sizes are by design. Reporter should feel free to open any other bugs if there are specific glitches or errors in the implementation of the design - those should go in Firefox::Theme.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Flags: blocking-firefox3? → blocking-firefox3-
Resolution: --- → INVALID
Also, reporter should feel free to right click the toolbar, select "Customize Toolbars", and click Use Small Icons.
1. UI rules for operating systems, please follow, especially if you claim you want to!
2. Since Firefox 3 is supposed to look like it fits in with the operating system, it should actually do so.
3. Having an almost standard interface that has one glaring non-standard piece will just make the one thing stand out all the more = bad.
4. Should not have to customize away from worse interface to better.
5. While there is perhaps reason for "keyhole" (back button used more than forward), no need to devote such a large area of interface to such a minor thing.
6. Especially on Mac, users expect a unified and standard interface.
7. Apple applications on Leopard all use the same standard back/forward buttons (Safari, Address Book, Finder, etc.), so Firefox should too.
8. The toolbar now takes up unnecessary space.
9. Depressed area around buttons is not only non-standard for Mac OS X, it is non-standard for the toolbar on which it is situated.
10. Triangle for pop-down menu is too tiny to click easily, and it is unclear whether it applies to the back or forward button, thanks to the depressed area (see #9).
11. It resembles a backwards play button. Internet cannot play backwards. Therefore: it seems erroneous.
12. The back button is a different shape from all the other Firefox toolbar buttons, and from all standard gradient-style buttons on Mac OS X toolbars, which makes it even more inappropriate.
13. From Alex Faaborg: "Our goals are to design an interface that is simple, modern, and visually lighter than previous versions of Firefox." This is heavy, not light, and seems overbearing on the toolbar.
14. "...a user interface that is both simpler..." Not simple, this is a custom and complex icon for a very simple functionality that has existed forever and is not especially exciting.
15. "The reason Linux isn’t shown above is that all of the feedback we’ve received so far indicates that Linux users would be happier with a theme that uses native GTK icons in the navigation toolbar, which rules out this type of customized visual treatment." This is incredibly Linux-centric and shows a basic disrespect for the desires of Mac users in general. As far as UI goes, Mac pays far more attention to it than does Linux, and is much more consistent across the board.
16. "The back button is larger than the forward button. We did this for two reasons: first, it’s a really important button. We could probably ship a Web browser with just a location bar and a back button, and a lot of users would be totally fine with that." FALSE.
17. "which isn’t the kind of thing you will necessarily consciously notice..." Also quite false. I am not the only person to have noticed this first thing upon viewing this new addition to the Firefox toolbar.
18. "This form serves as a visual cue that you are looking at Firefox 3..." Drawing attention away from the less important stuff, like, say, the content I suppose?
19. "In a previous post about the visual refresh for Firefox 3, I discussed our goal of visual integration with each platform. This strategy has a number of advantages, including presenting you with an interface that feels familiar, and reducing the negative feeling of adding something foreign to your system." This is exactly the reason things like this shouldn't be included by default. Firefox has add-ons and themes so that people who don't like the default don't have to use it, but that doesn't mean that the developers have to push something like this on the user by default, expecting them to change it themselves.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Confirmed on Windows Vista.  Please fire Alex so he and I can hang out and play Halo.  We're still working on Halo 2 and Halo 3 has been out for a while now.
->invalid, because it's fun to re-open and re-close and re-open and re-close issues that don't really fit into the open/closed system in the first place. 
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → INVALID
Reopened, because pompous Mozilla programmers and their cronies shouldn't be able to suppress the fact that some interface thing doesn't make any sense and needs to leave.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Actually, even if that were what were going on, they can.  That's part of the beauty of open source, and also what themes are for. But sure, leave the bug open.

FWIW IE is notorious for not following OS standards. Mac is always coming up with new things in iTunes (and anything else they come out with).  When someone does something *first* then of course it's going to stand out.

Clearly this was done on purpose with full knowledge of what programs do and don't have similar buttons. Please point out something new, or accept that you've had your chance to voice your opinion and wait to see whether enough users agree with you to change the devs' minds.
Lucy, iTunes style is now universal across all apps in Leopard.

Brian: Have you tried Camino?  It's a mozilla browser that may be more to your tastes.

See CaminoBrowser.org
yes, *now*, but they went through a few iterations to get there.  Just because no one else is doing it yet doesn't mean it's not a good idea.
I think talented people are always free to design and code corrections and improvements to the theme. Actually I signed up for this bug because I expected brilliant patches but I'm still waiting in vain. 
This is WONTFIX. Please see https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → WONTFIX
I'm not disagreeing that this is WONTFIX, but should pompous Brian be interested in talking some more, I suggest this blog post:

http://blog.mozilla.com/rob-sayre/2008/03/15/proto/
Duplicate of this bug: 422030
Duplicate of this bug: 422680
We shouldn't mark bugs like bug 422680 as duplicates of this one, because:

> should feel free to open any other bugs if there are specific glitches or
> errors in the implementation of the design
I really don't see what's new or valuable in the bug 422680 that's addressable with a resolution of Fixed. It's simply another "it looks bad" bug. 
John Gruber has weighed in on this issue.

http://daringfireball.net/2008/04/firefox_3_safari_3
Status: RESOLVED → VERIFIED
Updating the summary and severity to more accurately (and civilly) reflect the nature of this bug.
Alias: goodgod
Severity: major → enhancement
Summary: GOOD GOD THE BACK FORWARD BUTTON MAKES ME WANT TO DIE → Improve look and feel for BACK and FORWARD buttons
You need to log in before you can comment on or make changes to this bug.