When automatic/manual compaction of folder is triggered, cursor is moved to start of folder

RESOLVED DUPLICATE of bug 479064

Status

RESOLVED DUPLICATE of bug 479064
11 years ago
8 years ago

People

(Reporter: tux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.24 (Windows NT 5.2; U; en)
Build Identifier: version 3.0a1pre (2008031802)

If I browse folder and delete or move messages away and this triggers the auto compaction of folder due to more that xx Kb disk space being saved, the cursor moves at start of the list in folder after compaction is done.

Reproducible: Always

Steps to Reproduce:
1. Set automatic compaction when 20 Kb of disk space is saved (for example)
2. Move or delete mails in excess of that threshold from folder with lot of messages to trigger automatic compaction.

Actual Results:  
The cursor is moved to top of the list.

Expected Results:  
Cursor should stay on the mail where it was before the compaction started, it should not be reset to beginning of the folder.
Happens also if you manually compact folders.
Annoying to have to scroll back to your previous message.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080924032742 Shredder/3.0b1pre ID:20080924032742
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: When automatic compaction of folder is triggered, cursor is moved to start of folder → When automatic/manual compaction of folder is triggered, cursor is moved to start of folder
3-rd phenomenon of Bug 369643 Comment #0 ?
If so, as I wrote in Bug 369643 Comment #5, I couldn't reproduce problem on local mail folder with Tb trunk 2009/6/01 build on MS Win.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 479064
You need to log in before you can comment on or make changes to this bug.