Items disabled in Context menu in Bookmark Toolbar

VERIFIED DUPLICATE of bug 438909

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 438909
10 years ago
7 years ago

People

(Reporter: Jørgen Rasmussen, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9b5pre) Gecko/2008031806 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9b5pre) Gecko/2008031806 Minefield/3.0b5pre

When I open a bookmark from the bookmark toolbar, in a new tap, by right clicking it and chose "Open in a new tap" then close the tap by  right clicking on the tap and choose "Close tap", and try to open at new bookmark the same way, some of the menu items are disabled.

Reproducible: Always

Steps to Reproduce:
1.Open a bookmark in a new tap, by right clicking the bookmark on the bookmark toolbar, and choose "Open in a new tap"
2.Right click on the tap and choose "Close tap"
3.Right click on a bookmark in the bookmark toolbar and choose "Open in a new tap"
Actual Results:  
When I try to open a bookmark in a new tap (step 3), some menu items are disabled.
If you try again, the problem is gone. Until you try to go through steps 1 to 3 again.

Expected Results:  
The menu items should not be disabled.

Addons or no addons makes no difference.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk

Comment 1

10 years ago
Regression range:

works:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022504 Minefield/3.0b4pre
broken:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022604 Minefield/3.0b4pre

Comment 2

10 years ago
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-02-25+03%3A00&maxdate=2008-02-26+05%3A00&cvsroot=%2Fcvsroot
bug 419549?
Keywords: regression
OS: Windows XP → All

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

10 years ago
No, I just did a bisection, and it's definitely this changeset: http://hg.mozilla.org/mozilla-central/index.cgi/rev/421b8e80e454

Updated

10 years ago
Duplicate of this bug: 435957

Updated

10 years ago
Blocks: 403263

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 438909
No longer blocks: 403263

Updated

9 years ago
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.