Need script/command line method to tell running instance of Thunderbird to create new message with attachments

RESOLVED DUPLICATE of bug 287345

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 287345
10 years ago
8 years ago

People

(Reporter: Eric Long, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.15
Build Identifier: version 2.0.0.12 (20080213)

I have an application of my own that allows user to select files and mail them. I support Apple Mail, Entourage, and Eudora on Mac OS 10.4 or later.  I would like to support Thunderbird, but it doesn't support AppleScript.  The command line -compose argument is not adequate because it requires launching a new instance of the application.  This causes the application that is already running to post an alert saying you can't have multiple copies running at the same time. That's fine, but there is no way for me to tell the running copy of Thunderbird to do what my users will want, like there is for the other mail clients.  I brought this issue up here: <http://forums.mozillazine.org/viewtopic.php?t=639548>  The person responding felt it wasn't even a good idea to launch Thunderbird in interactive mode using the -compose argument.  I don't fill out the user's email for them, so it must be interactive.  At this time, I see no way we can support Thunderbird in our application.

Reproducible: Always

Steps to Reproduce:
I wish there were steps to do what I need to do properly.
Actual Results:  
Can't do it.

Expected Results:  
Can do it.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
-compose doesn't launch a new instance of the application if it's running (at least on linux, it uses the existing one)

thunderbird -compose attachment='file:///home/magnus/test.txt' works just fine

Then we also have another method of doing things:
thunderbird -remote "xfeDoCommand(composeMessage,to=name@domain,subject=FileName,attachment=file:///path/to/file,body=text)"

See http://www.mozilla.org/docs/command-line-args.html

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
>-compose doesn't launch a new instance of the application if it's running (at
>least on linux, it uses the existing one)
>thunderbird -compose attachment='file:///home/magnus/test.txt' works just fine

From the Terminal on Mac OS 10.5.2 while Thunderbird is running:

/Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin -compose attachment='file:///Users/eric/Desktop/MyDesk/medium_PETAmeat.jpg'

Result: Thunderbird displays an alert that says, "A copy of Thunderbird is already open. Only one copy of Thunderbird can be open at a time."

Its no different attempting to use other command line arguments.

Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

10 years ago
You shouldn't call "thunderbird-bin", but "thunderbird"
(unless it's some mac thing, but I don't think so, linux has the bin version too)
(Reporter)

Comment 4

10 years ago
Well, thunderbird-bin is the executable within the Thunderbird.app bundle on Mac.  There is no file named just thunderbird.  I'm not a command line jockey, but everything I can make out of what you're telling me just generates errors:

Macintosh-5:Applications eric$ thunderbird -compose attachment='file:///Users/eric/Desktop/MyDesk/medium_PETAmeat.jpg'
-bash: thunderbird: command not found

Macintosh-5:Applications eric$ /Applications/Thunderbird.app/Contents/MacOS/thunderbird -compose attachment='file:///Users/eric/Desktop/MyDesk/medium_PETAmeat.jpg'
-bash: /Applications/Thunderbird.app/Contents/MacOS/thunderbird: No such file or directory

Macintosh-5:Applications eric$ /Applications/Thunderbird.app -compose attachment='file:///Users/eric/Desktop/MyDesk/medium_PETAmeat.jpg'
-bash: /Applications/Thunderbird.app: is a directory

This works great, so long as there isn't already a running instance of the application:

Macintosh-5:Applications eric$ /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin -compose attachment='file:///Users/eric/Desktop/MyDesk/medium_PETAmeat.jpg'

If there is a running instance, I get the error alert described previously.



Comment 5

9 years ago
I get the same behavior Magnus is describing using Linux version 2.0.0.19.

Comment 6

9 years ago
I can confirm this is a bug in Thunderbird 2.0 pre 3 build from several days ago. Under OSX, executing a command-line instruction causes Thunderbird to try to launch again rather than executing it against the currently running application.


I would suggest that this task is a duplicate of #472891
This looks more like a DUP of bug 287345 to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 287345
You need to log in before you can comment on or make changes to this bug.