bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

On shared calendars when an alarm comes up calendars are changed to read only and alarms cannot be dismissed

RESOLVED FIXED

Status

Calendar
Provider: GData
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Mel Mehmet, Unassigned)

Tracking

Details

(Whiteboard: [gdata-0.5])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Provider for Google Calendar V 0.3.1

If one of the 3 of us puts an event in all three calendars we will each get 3 alarms. If you try to snooze or clear and alarm the calendars are changed to read only and you cannot dismiss it or snooze it. Even when the calendars are changed back from read only and you try to dismiss or snooze reminder they just go back to being read only.

Reproducible: Always

Steps to Reproduce:
1.one user enters an ovent in all calendars.
2.Another user trys to snooze or cancel reminder.
3.cannot cancel and calendar of user who entered event becomes read only.
Actual Results:  
Calendars become read only.

Expected Results:  
Should not become read only.
What version of Lightning do you use? Does this also happen with 0.8 RC1 or a newer nightly build?

Comment 2

11 years ago
I can confirm that this bug exists.

It is happening under the same conditions for multiple users that have Provider: GData installed.

The details of the error that we receive is as follows:

Error number: CAL_IS_READONLY
Description: User does not have permission to perform this modification. [note that participant overrides not  available on recurring events]

The office I work in is primarily a Mac environment. I am on OS X 10.4.10. Most of my co-workers have 10.4, a few are on 10.3 or 10.2, and we have one or two PCs (Windows XP).

All of the Macs have the same version of Thunderbird, 2.0.0.12 for Mac OS X. We are using the newest stable versions of Lightning (0.7), and Provider for Google Calendar (0.3.1).

Also, the Google Calendars that are involved are part of a Google Apps account.

I have installed the latest nightly version of Lightning (0.8, build 2008031718), and the bug remains with no changes.

I wanted to install the nightly version of Provider: GData, but I could not find it for OS X:
ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-mozilla1.8/mac-xpi

Does a Mac OS X version of the gdata-provider.xpi (0.4pre) exist?

Out of desperation, I installed the Linux version. There were no ill effects from doing so, but the bug remains intact.

If I can provide more information about this bug, I would be more than happy to.

I will install the the latest nightly builds of Lightning and GData on one of our PC machines and report back if I have different results with that configuration.
Our mac box is down, but since I have no platform specific components, its fine to use the package in the linux or windows directory.

From the error message you posted, it seems you don't have enough access to the calendar, or you are trying to do something that is not supported by google.

What happens when an alarm is dismissed, is that a certain gd:extendedProperty tag is added. It seems its not supported to add this to a different user's calendar on a certain occurrence.

I'll try to reproduce this myself soon and then either file a google bug or look for a workaround.

Confirming per comment #2
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

11 years ago
(In reply to comment #1)
> What version of Lightning do you use? Does this also happen with 0.8 RC1 or a
> newer nightly build?
> The version of Lightning I am using is 0.7 - I am not sure what you mean by 0.8RC1 or a newer nightly build!




(Reporter)

Comment 5

11 years ago
(In reply to comment #3)
> Our mac box is down, but since I have no platform specific components, its fine
> to use the package in the linux or windows directory.
> 
> From the error message you posted, it seems you don't have enough access to the
> calendar, or you are trying to do something that is not supported by google.
> 
> What happens when an alarm is dismissed, is that a certain gd:extendedProperty
> tag is added. It seems its not supported to add this to a different user's
> calendar on a certain occurrence.
> 
> I'll try to reproduce this myself soon and then either file a google bug or
> look for a workaround.
> 
> Confirming per comment #2
> 

(In reply to comment #3)
> Our mac box is down, but since I have no platform specific components, its fine
> to use the package in the linux or windows directory.
> 
> From the error message you posted, it seems you don't have enough access to the
> calendar, or you are trying to do something that is not supported by google.
> 
> What happens when an alarm is dismissed, is that a certain gd:extendedProperty
> tag is added. It seems its not supported to add this to a different user's
> calendar on a certain occurrence.
> 
> I'll try to reproduce this myself soon and then either file a google bug or
> look for a workaround.
> 
> Confirming per comment #2
> 

Thank you for your help.

Comment 6

11 years ago
Mel, Lars is referring to version that is currently in development, but hasn't been officially released to the public yet, 0.8 in the case of Lightning. This version can potentially be unstable, but should be fresher, with bug fixes and new features.

In the case of both Lightning and GData, the newest stable public version is from  October, nearly six months old. But nightly version, true to its name, is from last night, less than a day old.

It looks like you are on Windows, so you'll want these versions: ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-mozilla1.8/windows-xpi/

I hope that helps, but I'm just an end-user, so don't take my word as canon!
(Reporter)

Comment 7

11 years ago
Thanks for this Josh.
(Reporter)

Comment 8

11 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.12)
> Gecko/20080201 FireFox/2.0.0.12
> Build Identifier: Provider for Google Calendar V 0.3.1
> 
> If one of the 3 of us puts an event in all three calendars we will each get 3
> alarms. If you try to snooze or clear and alarm the calendars are changed to
> read only and you cannot dismiss it or snooze it. Even when the calendars are
> changed back from read only and you try to dismiss or snooze reminder they just
> go back to being read only.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.one user enters an event in all calendars.
> 2.Another user tries to snooze or cancel reminder.
> 3.cannot cancel and calendar of user who entered event becomes read only.
> Actual Results:  
> Calendars become read only.
> 
> Expected Results:  
> Should not become read only.
> 

ONE THING I FORGOT TO MENTION IS THAT TWO OF THE LAPTOPS USING THIS ARE RUNNING VISTA AND ONE IS RUNNING W98 PROFFESIONAL

Updated

10 years ago
Summary: We have 3 seperate users of this, all sharing calendars. When a reminder comes up calendars are changed to read only and cannot be dismissed. → On shared calendars when an alarm comes up calendars are changed to read only and alarms cannot be dismissed
Duplicate of this bug: 425409
I have the feeling this is a Google Apps problem. Mel, are you also using Google Apps?

Josh, Mel, could you try to reproduce this with a non-apps calendar?
(Reporter)

Comment 11

10 years ago
I know that I am not using Google Apps. When you say try to reproduce using non-apps calendar, what does that mean?
With non-apps calendar I meant a calendar not from google apps but directly from google.com. My new theory is the following:

* always happens with Google Apps calendars
* also happens for non-owned, shared standard google calendars
(Reporter)

Comment 13

10 years ago
The calendars that are being used are directly with Google.com rather than Google Apps. 

I had not seen Apps before now.

Hope this helps.

Comment 14

10 years ago
Phillip, I did some testing, and I can confirm that this bug is reproducible with a standard gmail account.

For this test, I used Ubuntu 7.10, Thunderbird 2.0.0.12, and the nightly versions of Lightning and Google Provider. Dismissing an event reminder from a different gmail account(non-apps), still resulted in the calendar being locked.

Comment 15

10 years ago
I can also confirm that this happens on a standard gmail account (Ubuntu 8.04b, Thunderbird 2.0.0.12, standard versions of Lightning + Google Provider).  I am able to snooze reminders, but not dismiss them from my Thunderbird account.
(Reporter)

Comment 16

10 years ago
We havent been able to snooze or dismiss reminders without the calendar locking.

Comment 17

10 years ago
Happening to me as well using the latest regular public installs. 

Standard gmail account.
Ubuntu 8.04.
Thunderbird 2.0.0.14.
Lightning 0.8 build 2008033118.
Provider for Google Calendar 0.4.

It happens when I receive a recurring event request from someone else and add to my calendar through the gmail.com web interface. It shows up with a 15 minute pop-up reminder. Later in thunderbird the reminder pops up and I am unable to snooze or dismiss it. I can close the popup window but it returns every minute and there is no way to turn it off. I tried just removing the reminder from google.com/calendar in advance but a 15 minute reminder still shows in thunderbird and I am unable to remove it there.

HOW TO KILL THE ANNOYING REMINDER POP-UP: 
After the event go into the google.com/calendar web interface, find the event and delete that occurrence. Restart thunderbird and reload remote calendars if necessary. Hope that helps somebody :)

Yes, I thought it may be an issue with events from other users. Mel, Steven, Josh, can you confirm that the events in question actually come from a different calendar?

I could possibly work around by suppressing alarms on recurring items where the user is not the organizer.

Comment 19

10 years ago
I'm using Goggle Calendar Sync to sync my Exchange Calendar to Google Calender and I'm then using then using Lightning + Google Provider to access this calender from Thunderbird. 

I'm currently seeing this problem on recurring items.
Chris, are these recurring items also from a different calendar (i.e did someone else create the event on your calendar?)

Comment 21

10 years ago
All the events that I have problems with have someone who isn't me as the "Created By"

I tried creating a test recurring appointment as myself and this can be dismissed. So it does look like it is just these items that are having problems.

Would it be useful if someone can create a calendar that reproduces these issues?

Comment 22

10 years ago
I've just created a brand new calendar and added an event from another account. When I add this test account into the provider I can see this issue where the event cannot be dismissed or snoozed. 

Because this is a brand new calender I'm more than happy to provide access to it if anyone wants to be able to see this bug for themselves. Just send me an e-mail and I will give you the login details.
Note to self: do not set X-Props or anything else on events where user is not the organizer.

Comment 24

10 years ago
Confirming the same problem using Swiftdove 2.0.0.12 on Ubuntu 8.04 amd64 using Gcaldaemon to sync.  Every time I try to dismiss a reminder Gcaldaemon communicates with Google, and the reminder comes back in 15 minutes.
OS: Windows Vista → All
Hardware: PC → All
This  may be "fixed" with bug 428544.
Depends on: 428544
If this issue persists after the next nightlies (2008-09-04), please reopen.

-> FIXED by bug 428544
Resolving as FIXED according to previous comment.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [gdata-cvs]
Whiteboard: [gdata-cvs] → [gdata-0.5]
You need to log in before you can comment on or make changes to this bug.