Incorrect Icon for Pop-up Blocked in StatusBar

VERIFIED FIXED

Status

()

Firefox
Theme
P2
major
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

The Icon for the Pop-up Blocked is incorrect. 

See here on Vista HP SP1 
http://img247.imageshack.us/img247/6348/blockiconrx6.jpg

reed on IRC advised the icon used is:
browser/themes/winstripe/browser/Info.png 

Not sure what it should be ...

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008032204 Minefield/3.0b5pre Firefox/3.0 ID:2008032204

Updated

10 years ago
Blocks: 424028
We have:
browser/themes/winstripe/browser/Info.png
browser/themes/winstripe/browser/Info-aero.png

While the name is "Info", it's really the (pop-up, image, whatever) "blocked"
icon. See http://mxr.mozilla.org/firefox/search?string=Info.png for some uses
in the code.
Flags: blocking-firefox3?
Here's what Linux and Mac use:
http://mxr.mozilla.org/firefox/source/browser/themes/gnomestripe/browser/Info.png
http://mxr.mozilla.org/firefox/source/browser/themes/pinstripe/browser/Info.png

Mac's icon looks weird, too, but it's the same one that was used for Firefox 2. Linux's icon is the proper "blocked" icon.
This happened because we were subbing in a different icon here temporarily, I think it'll be fixed. Alex: can you confirm?
Flags: blocking-firefox3? → blocking-firefox3-
Priority: -- → P2
>This happened because we were subbing in a different icon here temporarily, I
>think it'll be fixed. Alex: can you confirm?

Yeah, in the next drop we will have this back to a pop-up blocked image, and another icon added for the more generic info icon, at which point this bug will be resolved.
New Icons landed, and the Icon is still wrong, still showing the Info Icon.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041615 Minefield/3.0pre Firefox/3.0 ID:2008041615
We have the new icon, will land shortly.
Depends on: 429689
Fixed by landing of bug 429689.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified fixed using Vista HP SP1
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041904 Minefield/3.0pre Firefox/3.0 ID:2008041904 <-latest hourly
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.